Vendor Template Issues

  • Posts: 51
  • Thank you received: 1
  • Hikamarket Multivendor Hikashop Business
2 months 2 weeks ago #281779

-- HikaShop version -- : 3.2.0
-- HikaMarket version -- : Multivendor 1.7.3
-- Joomla version -- : 3.8.1

Using Hikamarket multivendor and in my configuration/main I have set one default product template, which I would assume would be assigned to all new vendors when the register. But new vendors have no product template assigned to them. I can assign it if I go in the back end to the Vendor section, open the new vendor and assign it. Shouldn't it be assigned by default? Am I missing something?

Please Log in or Create an account to join the conversation.

  • Posts: 21770
  • Thank you received: 3404
  • MODERATOR
2 months 2 weeks ago #281790

Hello,

Would it be possible to have more details about your HikaMarket "main" configuration ?
When a vendor do not have a product template set ; the default product template will be used automatically.
So when a product template is define in the configuration, you can't configure a vendor to not have a product template, since the "none" will fallback on the configuration setting.
That's why I'm surprise of your bug description and that I need more details to understand how is your set-up.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 51
  • Thank you received: 1
  • Hikamarket Multivendor Hikashop Business
2 months 2 weeks ago #281812

Thanks for the reply Jerome. I'm attaching a couple of screenshots showing my one product template and that I have it set as default in the config. But any time a new vendor registers, there is no product template assigned. Looking at them from the backend in the Hikamarket/Vendor area, the field that says "Vendor Product Template" is set to "None". I can change it in the back end to the default, but it should automatically assign right?

Attachments:
Last Edit: 2 months 2 weeks ago by Jerome. Reason: removing duplicate images

Please Log in or Create an account to join the conversation.

  • Posts: 21770
  • Thank you received: 3404
  • MODERATOR
2 months 2 weeks ago #281853

Hello,

I got the impression that there is a mis-understanding.

I would assume would be assigned to all new vendors when the register

What do you mean with "assigned to all new vendors" ?

In my previous message, I explained you how the template feature is working :

When a vendor do not have a product template set ; the default product template will be used automatically.


So yes, it is normal that there is no product template assignation since the "default" is used when there is no assignation.
The setting is not there to perform an assignation ; it is there to provide the default (fallback) value.
And you can override that value for your vendors in case that you want to propose a different template than the default one.

The counter of assignation is there to indicate how many vendors have that assignation but for the default one, there is no counter and the value "default template" will be displayed in the listing.
But if you do set the template to some vendors (while it's the default one), yes you won't see the "default template" information but the counter of how many vendor have that template assigned.

For what I can understand, there is no bug or issue.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 51
  • Thank you received: 1
  • Hikamarket Multivendor Hikashop Business
2 months 2 weeks ago #281896

I'm beginning to wonder how I'm so dumb on things sometime...of course. Makes perfect sense. Thanks for the great help!

Please Log in or Create an account to join the conversation.

Moderators: Obsidev
Time to create page: 0.061 seconds
Powered by Kunena Forum