- Posts: 256
- Thank you received: 2
Fatal Error : memory in Hikashop administrator
- dancingkazzaf
-
Topic Author
- Offline
Less
More
12 years 4 months ago #154678
by dancingkazzaf
Fatal Error : memory in Hikashop administrator was created by dancingkazzaf
-- url of the page with the problem -- :
mywebsite.com/mypage
-- HikaShop version -- : 2.3.0
-- Joomla version -- : 3.2.3
-- PHP version -- : 5.3.28
-- Browser(s) name and version -- : XXXXX x.x.x
-- Error-message(debug-mod must be tuned on) -- : Fatal error: Allowed memory size of 25165824 bytes exhausted (tried to allocate 461070 bytes) in /home/sites/claireabellascloset.co.uk/public_html/beta/libraries/joomla/document/html/html.php on line 693
I receive this error when ever I try to access configuration setting, products, orders etc. in Hikashop. I did also have it happen on font end but solved this by increasing memory size to 64m. Is there anyway to stop it happening in Hikashop administrator?
Thanks
-- HikaShop version -- : 2.3.0
-- Joomla version -- : 3.2.3
-- PHP version -- : 5.3.28
-- Browser(s) name and version -- : XXXXX x.x.x
-- Error-message(debug-mod must be tuned on) -- : Fatal error: Allowed memory size of 25165824 bytes exhausted (tried to allocate 461070 bytes) in /home/sites/claireabellascloset.co.uk/public_html/beta/libraries/joomla/document/html/html.php on line 693
I receive this error when ever I try to access configuration setting, products, orders etc. in Hikashop. I did also have it happen on font end but solved this by increasing memory size to 64m. Is there anyway to stop it happening in Hikashop administrator?
Thanks
Please Log in or Create an account to join the conversation.
Less
More
- Posts: 12953
- Thank you received: 1778
12 years 4 months ago #154717
by Mohamed Thelji
Replied by Mohamed Thelji on topic Fatal Error : memory in Hikashop administrator
Hello,
Can you set your allowed memory size to :
And test it again ?
Thanks
Can you set your allowed memory size to :
Code:
memory_limit = 128M
And test it again ?
Thanks
Please Log in or Create an account to join the conversation.
- dancingkazzaf
-
Topic Author
- Offline
Less
More
- Posts: 256
- Thank you received: 2
12 years 4 months ago #154825
by dancingkazzaf
Replied by dancingkazzaf on topic Fatal Error : memory in Hikashop administrator
Thanks I had tried so many different memory limits yesterday and nothing was working. But just changed it to that and it worked straight away thanks.
Please Log in or Create an account to join the conversation.
- dancingkazzaf
-
Topic Author
- Offline
Less
More
- Posts: 256
- Thank you received: 2
12 years 4 months ago #154854
by dancingkazzaf
Replied by dancingkazzaf on topic Fatal Error : memory in Hikashop administrator
I have got another problem now. If i try to increase the image size to 200px i get the same fatal error memory size on the front end now. How much do I need to increase my PHP memory size too. I have only put one product on there so far.
Please Log in or Create an account to join the conversation.
12 years 4 months ago #154857
by Jerome
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Replied by Jerome on topic Fatal Error : memory in Hikashop administrator
Hi,
You have ot know that 24MB is very very few if you want to process images.
Changing the thumbnail size means : reprocessing the images to generate the new thumbnails.
It is something which require some memory because it has to load the image (uncompressed in the server memory), generate the thubmnail and save the new image.
Depending the size of your images, it can use some memory.
But once the thumbnails ready, it won't consume this memory anymore (except if you add new images).
Regards,
You have ot know that 24MB is very very few if you want to process images.
Changing the thumbnail size means : reprocessing the images to generate the new thumbnails.
It is something which require some memory because it has to load the image (uncompressed in the server memory), generate the thubmnail and save the new image.
Depending the size of your images, it can use some memory.
But once the thumbnails ready, it won't consume this memory anymore (except if you add new images).
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
Please Log in or Create an account to join the conversation.
- dancingkazzaf
-
Topic Author
- Offline
Less
More
- Posts: 256
- Thank you received: 2
12 years 4 months ago #154967
by dancingkazzaf
Replied by dancingkazzaf on topic Fatal Error : memory in Hikashop administrator
Oh right okay, but I have changed the memory limit to 128M so surely I shouldn't get the problem anymore? Are you saying I need to re-save the image as a smaller file size for the thumbnail?
Please Log in or Create an account to join the conversation.
12 years 4 months ago #154981
by nicolas
Replied by nicolas on topic Fatal Error : memory in Hikashop administrator
So if you changed the memory limit to 128M, you should now get another error message with the "Allowed memory size" with a way bigger number. Could you copy/paste the new message that you have now ?
If you still have an error message with something around 25 000 000, it means that the modification to 128M hasn't been taken into account by your web server and you should contact your hosting company in order to know how to increase the memory limit for your web server based on how they set it up.
If you still have an error message with something around 25 000 000, it means that the modification to 128M hasn't been taken into account by your web server and you should contact your hosting company in order to know how to increase the memory limit for your web server based on how they set it up.
Please Log in or Create an account to join the conversation.
Time to create page: 0.218 seconds