Address fileds not showing on checkout

  • Posts: 13
  • Thank you received: 0
8 years 2 weeks ago #2551

Hello,

I have turned registration off and have address as the first form that should come up on check out.

The problem I have is that it does not show any fields on the address page. Custom fields for address is turned on and should be working:

mbdsigngroup.com

Workflow is:

address,cart_coupon_payment_confirm_shipping_status_fields,end

If I add the "login" to the workflow and login as myself, it picks up the "billing" address. It never asks me for shipping address. With no registration, I would expect a screen that asks for email, address, etc.

I couldn't find this in the documentation anywhere...

Please Log in or Create an account to join the conversation.

  • Posts: 64159
  • Thank you received: 9258
  • MODERATOR
8 years 2 weeks ago #2553

You need to keep the login view.

That's the login view which displays the address form with the email fields etc. The address view enables you to select between several addresses for billing and shipping.

If you don't have the shipping address part of the address view, that's probably because you didn't enter a weight for the products in the cart and thus, the system considered them as virtual goods which do not require shipping.

You can remove the login form from the login view with a bit of CSS : www.hikashop.com/en/support/forum/4-how-to/2486-login.html#2487

Please Log in or Create an account to join the conversation.

  • Posts: 13
  • Thank you received: 0
8 years 2 weeks ago #2556

That's not fixing it....

Now i get the login form (with "registration not allowed") and nothing else on that screen.

I put weights into all the products, and still not getting a shipping address.

Please Log in or Create an account to join the conversation.

  • Posts: 13
  • Thank you received: 0
8 years 2 weeks ago #2559

Ok - once i login, i am now getting the shipping field and billing fields.

Just need to turn off the login piece.

I went to the link you referrenced and it doesn't really help.

It says to put a line of code in the CSS, but I can't figure out what file they are referring to.

Doing this in CSS doesn't seem right - why is there a configuration flag for "no registration" yet you can't disable the login form without going to CSS.

Seems like an update that's needed to the software.

Please Log in or Create an account to join the conversation.

  • Posts: 64159
  • Thank you received: 9258
  • MODERATOR
8 years 2 weeks ago #2560

Yes,

Actually when you turn off the registration in HikaShop the registration activation option of joomla is still checked in the login view where it should not.
That's something we already corrected on our end and which will be added to next release.

In the mean time, you can go in the menu Display->Views and search for the view file login. Edit it and change the code

if ($allowRegistration){
by the code
if ($allowRegistration || $this->simplified_registration == 2){
Than, you will have the fields displayed.

Please Log in or Create an account to join the conversation.

  • Posts: 64159
  • Thank you received: 9258
  • MODERATOR
8 years 2 weeks ago #2563

The "no registration" option enables you to deactivate the registration to joomla. It doesn't mean that you want to disable the login part on the left. That's why you have to remove it manually.

Please Log in or Create an account to join the conversation.

  • Posts: 13
  • Thank you received: 0
8 years 2 weeks ago #2572

Brilliant!

Working perfectly now!

Nicolas - you have a great product and amazing support!

I'm glad I purchased and will do so again!

-Dave

Please Log in or Create an account to join the conversation.

Time to create page: 0.087 seconds
Powered by Kunena Forum