Invoice display error in line 86 show.php

  • Posts: 1
  • Thank you received: 0
8 years 5 days ago #3114

Hey

I have it set up so users don't enter any billing or shipping address (they send that to me through an encrypted form)
Checkout works fine, but if you view your order/invoice i get this error right underneath where it says 'Billing Address' on the invoice

Warning: Invalid argument supplied for foreach() in /home/domains/public_html/components/com_hikashop/views/order/tmpl/show.php on line 86

I haven't modified show.php at all, just wondering if it's because i have no address registration through joomla/hikashop thkx

Please Log in or Create an account to join the conversation.

  • Posts: 64159
  • Thank you received: 9258
  • MODERATOR
8 years 5 days ago #3119

Hi,

Yes, that's indeed because you don't have the registration step and because on your hosting you ahve the display of errors activated.
The best will be to completely removing the billing address part since anyway you don't have addresses. We have done modifications to that file in that way and it will be available for next version.

In the mean time, you can replace that file by the one in the archive in this post

File Attachment:

File Name: show-20101208.zip
File Size:2 KB

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 0
8 years 22 hours ago #3324

Hi,

I am also seeing the same issue. I don't request an address or a shipping method from my buyer since we deliver products electronically. I upgraded my shop.php to the one you provided ,but I am seeing the following errors when my customers check their order status.

Billing address
Warning: Invalid argument supplied for foreach() in ......./components/com_hikashop/views/order/tmpl/show.php on line 77

Shipping address
Warning: Invalid argument supplied for foreach() in ......./components/com_hikashop/views/order/tmpl/show.php on line 94

Last Edit: 8 years 22 hours ago by tmetti.

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 0
8 years 22 hours ago #3325

Ok, I was able to fix the issue by changing:

<?php if(!empty($this->element->billing_address)){ ?>

to:

<?php if(!empty($this->element->billing_address->address_country)){ ?>

I just picked a NULL var in the billing_address dump.

You may want to include my patch , or a similar one in your next update.

Please Log in or Create an account to join the conversation.

  • Posts: 64159
  • Thank you received: 9258
  • MODERATOR
8 years 21 hours ago #3327

That's actually a different issue. Apparently you disabled/removed all the custom address fields which resulted in these warnings.We will correct it for next release.

Thanks for your report.

Please Log in or Create an account to join the conversation.

Time to create page: 0.088 seconds
Powered by Kunena Forum