Welcome, Guest
Username: Password: Remember me

TOPIC: Billing address edit

Billing address edit 1 year 7 months ago #63717

  • nikmackey
  • nikmackey's Avatar
  • OFFLINE
  • Posts: 60
  • Thank you received: 1
In the Cart where the opportunity to change your address details.

On either the billing address or shipping address the problem is the same.

If one clicks the 'New' button nothing happens other than the page refreshes. If one clicks on the edit icon (A page with pencil) then an unformatted, non-templated page appears with the form to make the change. Either how can I get this to appear on the template based page or maybe to appear in a Modul or thickbox style window?
The administrator has disabled public write access.

Re: Billing address edit 1 year 7 months ago #63864

  • nicolas
  • nicolas's Avatar
  • NOW ONLINE
  • Posts: 36276
  • Thank you received: 3688
  • MODERATOR
Hi,

This means that you have javascript errors on your pages which prevents the joomla modal library to initialize the edition popups properly.
You can see the errors in the javascript error console of your browser.

This often comes from templates/modules using the javascript library jquery which causes a conflict with mootools:
www.hikashop.com/en/support/documentatio...ty-issues.html#modal
The administrator has disabled public write access.

Re: Billing address edit 1 year 7 months ago #63919

  • nikmackey
  • nikmackey's Avatar
  • OFFLINE
  • Posts: 60
  • Thank you received: 1
Hi, Thank you for your response.

I have been through other plugins that may be loading conflicting scripts. I have also disabled a couple of scripts that were part of the template.

It seems I still have a problem

I've attached a screen grab of the effective code in the head of this page. Maybe you can see the problem.


Screen_shot_2012-09-05_at_09_31_21.png
The administrator has disabled public write access.

Re: Billing address edit 1 year 7 months ago #63924

  • nikmackey
  • nikmackey's Avatar
  • OFFLINE
  • Posts: 60
  • Thank you received: 1
I just turned on 'Debug system' in global config to help find the problem.

With this on the Modal window works correctly. Turned off it doesn't.

I have tried to work out which scripts were added that aided this function in the process and failed to identify the active script.

Any more thoughts on this. There are no other plugins active on this page other than those directly related to Hikashop or Joomla default plug ins.
The administrator has disabled public write access.

Re: Billing address edit 1 year 7 months ago #63927

  • nikmackey
  • nikmackey's Avatar
  • OFFLINE
  • Posts: 60
  • Thank you received: 1
I have resolved the problem by hitting it with a very big hammer.

I have loaded all the scripts loaded when debug is switched on

<script src="/media/system/js/core-uncompressed.js" type="text/javascript"></script>
<script src="/media/system/js/mootools-more-uncompressed.js" type="text/javascript"></script>
<script src="/media/system/js/validate-uncompressed.js" type="text/javascript"></script>
<script src="/media/system/js/modal-uncompressed.js" type="text/javascript"></script>

This seems to fix the issue.

I suspect I am now going to have problems elsewhere.
The administrator has disabled public write access.

Re: Billing address edit 1 year 7 months ago #63930

  • nikmackey
  • nikmackey's Avatar
  • OFFLINE
  • Posts: 60
  • Thank you received: 1
For anyone following this I progressively deleted the above scripts until the modal function failed.

The only one of those scripts that had to be manually loaded, IE in the template is

<script src="/media/system/js/modal-uncompressed.js" type="text/javascript"></script>

I'm sure this is not a good way to manage this problem but as I can't find which plugin function is creating the issue...

Final question

Why do I get both the 'Edit' icon and the 'New' button showing? Both appear to do the same function. Can I get rid of the edit button?
Last Edit: 1 year 7 months ago by nikmackey.
The administrator has disabled public write access.

Re: Billing address edit 1 year 7 months ago #63990

  • nikmackey
  • nikmackey's Avatar
  • OFFLINE
  • Posts: 60
  • Thank you received: 1
Ok, I have the edit button matter sorted.

Thanks

C
The administrator has disabled public write access.

Re: Billing address edit 1 year 7 months ago #64175

  • nicolas
  • nicolas's Avatar
  • NOW ONLINE
  • Posts: 36276
  • Thank you received: 3688
  • MODERATOR
I wouldn't have guessed that. That's a good way to make it work.It shouldn't cause problems to fix it like that.
The administrator has disabled public write access.
Time to create page: 0.485 seconds
Powered by Kunena Forum