× You can talk here in German about HikaShop. Please understand that we do not speak German at HikaShop and we can't offer support in German.

Bin am verzweifeln, Verlinkung`s Probleme ...

  • Posts: 19
  • Thank you received: 0
  • Hikashop Business
10 months 2 weeks ago #283401

-- url of the page with the problem -- : www.4fashionlovers.at/cms
-- HikaShop version -- : Business 3.2.1
-- Joomla version -- : 3.8.2
-- PHP version -- : 5.6.32
-- Error-message(debug-mod must be tuned on) -- : Ich bin am Verzweifeln, und das schon seit Tagen.
Ich baue gerade einen Seite: www.4fashionlovers.at/cms/
und habe folgendes Problem.

Bie der Vlerinkung egal welche ich mache schreibt mir Joomla
immer folgenden Nachsatz an doie Verlinkungs-URL: &Itemid=101
Dadurch funktioniert kein Link.

Habe Hika-Shop Business im Einsatz

Also wenn ich folgende Verlikung mache:
index.php?option=com_users&view=reset

Dann wird aus der URL im Frontend immer
index.php?option=com_users&view=reset&Itemid=101


Hatt jemand eine Idee an was das liegen könnte ?

Ich bin am Verzweifeln, und das schon seit Tagen.
Ich baue gerade einen Seite: www.4fashionlovers.at/cms/
und habe folgendes Problem.

Bie der Vlerinkung egal welche ich mache schreibt mir Joomla
immer folgenden Nachsatz an doie Verlinkungs-URL: &Itemid=101
Dadurch funktioniert kein Link.

Habe Hika-Shop Business im Einsatz
Hat das was mit HIKA-Shop zu tun ?

Also wenn ich folgende Verlikung mache:
index.php?option=com_users&view=reset

Dann wird aus der URL im Frontend immer
index.php?option=com_users&view=reset&Itemid=101

Betrifft nur alles was ich direkt im Joomla verlinke,
nichts über Module (z.b. Menü, usw)

Hatt jemand eine Idee an was das liegen könnte ?

Last Edit: 10 months 2 weeks ago by eltirol.

Please Log in or Create an account to join the conversation.

  • Posts: 1803
  • Thank you received: 600
  • Hikamarket Multivendor Hikashop Business
10 months 2 weeks ago #283404

Hi,

das hat nichts mit HikaShop zu tun.

Offenbar hast du einen Override für die Passwort-Reset Seite (entweder selbst erstellt oder von deinem Template-Provider oder sonst jemandem), denn die Seite sieht nicht wie der Joomla-Standard aus.

Schau mal hier im Screenshot, da ist der Link samt "&Itemid=101" für den Button hinterlegt. Editiere den Override und entferne den Zusatz im Link, und es sollte gut funktionieren.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 0
  • Hikashop Business
10 months 2 weeks ago #283412

Und wie kann ich den Override editieren, ich steh auf der Leitung

Please Log in or Create an account to join the conversation.

  • Posts: 1803
  • Thank you received: 600
  • Hikamarket Multivendor Hikashop Business
10 months 2 weeks ago #283420

Hi,

Offenbar hast du den Override nicht selbst erstellt. Du solltest dich also an denjenigen wenden, der das gemacht hat. Wie gesagt, vielleicht der Lieferant deines Joomla-Templates oder wer sonst auch immer Zugang zu den Dateien in deiner Site gehabt haben mag.

Schau mal ob es die Datei

/templates/tz_henry_joomla/html/com_users/login/default_login.php
gibt. Da müsste dein komischer Link mit "&Itemid=101" auftauchen.

Sorry, aber das gehört alles nicht in dieses HikaShop-Forum. Nochmals: bei weiteren Problemen in dieser oder anderen non-HikaShop Angelegenheiten bitte an den Verursacher wenden. ;)

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 0
  • Hikashop Business
10 months 2 weeks ago #283423

so ganz stimmt das nicht, habe das template bei templaza gekauft und hier ist die free version von hzikahsop dabei.
dieses template wird bei hikashop als, kompatibles template angezeigt.

ich habe aber die business version von hikashop gekauft und diese installiert.

templaze meinte zu diesem thema:
Wenn jemand das original "free" version von ihnen mit einer gekauften version überschreibt,
dann liegt das problem bei hika shop.

Und wer hat das Problem ich als webdesigner ...

Nein in diesem /templates/tz_henry_joomla/html/com_users/login/default_login.php
gibt es kein item101

Ich habe jetzt nochmals zwei links gemacht, hier sieht man es besser was hier nochmals gemacht wird,
unterschiedliche items onbwohl selber link ?
www.4fashionlovers.at/cms/index.php/loginarea

Last Edit: 10 months 2 weeks ago by eltirol.

Please Log in or Create an account to join the conversation.

  • Posts: 1803
  • Thank you received: 600
  • Hikamarket Multivendor Hikashop Business
10 months 2 weeks ago #283428

Sorry, aber unumstrittene Tatsache ist, dass HikaShop (und das gilt für alle Editionen) nichts enthält oder macht, das diese Login-Seite samt Passwort-Reset-Link erzeugt oder verändert. das ist so sicher wie das berühmte Amen in der Kirche.

An HikaShop liegt es also wirklich nicht, davon kann dieser Button und Link nicht herkommen.

Ich wiederhole nochmal: es rührt woanders her. Wenn es die o.g. Datei nicht gibt, dann hat womöglich jemand die Joomla-Core-Datei überschrieben (was man natürlich weder tun sollte noch muss). Aber das lässt sich aus der Ferne nicht feststellen, da musst du schon selber forschen.
So oder so, hier bist du wirklich am falschen Platz damit -- aus mehrfach genanntem Grund. Dies hier hat mit Basis-Joomla zu tun, nicht HikaShop. (Nimm's mir nicht übel, aber dies und auch alles vorher genannte sollte einem Webdesigner auch klar sein.)

Viel Glück.

Last Edit: 10 months 2 weeks ago by lousyfool. Reason: Tippfehler im ersten Satz

Please Log in or Create an account to join the conversation.

  • Posts: 1803
  • Thank you received: 600
  • Hikamarket Multivendor Hikashop Business
Time to create page: 0.100 seconds
Powered by Kunena Forum