Carousel is not working on main page

  • Posts: 34
  • Thank you received: 1
2 years 10 months ago #193561

-- HikaShop version -- : 2.4.0
-- Joomla version -- : 3.3.6
-- PHP version -- : 5.3.27
-- Browser(s) name and version -- : Chrome 41.0.2272.76 m

Hi,
Please help me, how I could modify the setup of the carousel of the random products modul.
On the main page the sliding function (and if it's enabled nor the carousel buttons) is not working
but on subpages it's working.
I use the same random products modul on the main page and on the subpages too.

Thank you for your help in advance.

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 1
2 years 10 months ago #193592

I noticed, that the cart buttons have styles assigned to them from CSS,
but in the admin under display settings I have normal button style setup.
The sub pages have according to the setup normal button style.

Please Log in or Create an account to join the conversation.

  • Posts: 60535
  • Thank you received: 8531
  • MODERATOR
2 years 10 months ago #193638

Hi,

I see a javascript error on the page.
Try to change the line:
$('myElement_".$this->params->get('main_div_name')."_".$this->params->get('main_div_name')."_".$this->row->category_id."').set('morph', {

to:
$('myElement_".$this->params->get('main_div_name')."_".$this->row->category_id."').set('morph', {

in the file "listing_fade" of the view "category" for your frontend template via the menu Display>Views and that should fix the javascript error and hopefully, allow the slider to work.

The following user(s) said Thank You: plengyel

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 1
2 years 10 months ago #193714

Hi Nicolas,

It's working, fantastic !

Thank you for your help.

Please Log in or Create an account to join the conversation.

  • Posts: 1
  • Thank you received: 0
10 months 1 week ago #264359

hi
my Carousel is not working on main page
How can I correct it

Please Log in or Create an account to join the conversation.

  • Posts: 21769
  • Thank you received: 3404
  • MODERATOR
10 months 1 week ago #264795

Hello,

Please create a new thread for your question and provide basic details to explain your issue.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

Time to create page: 0.088 seconds
Powered by Kunena Forum