Unable to finalise order if address is submitted

  • Posts: 117
  • Thank you received: 2
  • Hikashop Business
3 months 1 day ago #299141

-- HikaShop version -- : 4.0.0
-- Joomla version -- : 3.8.11
-- PHP version -- : 7.1.20

Hello!

We're having a strange issue with the checkout where if you submit the address (not the order) and the country is within EU, then the order won't submit / continue to the selected payment method, when you press the "Finish Order" button.

If you however select a country outside of the EU then everything works as expected, this is also the case that if you avoid submitting the address and instead proceed to click the "Finish order" everything is working.

We've used the default Joomla template to ensure that it's not one of the views interfering. We have also checked our tax zones / rates and such and nothing has changed / everything seems to be in order.

This is a very strange issue.

Please Log in or Create an account to join the conversation.

  • Posts: 64471
  • Thank you received: 9312
  • MODERATOR
3 months 1 day ago #299145

Hi,

It's a shame you didn't give a link to the shop so that we could reproduce the problem, or a screenshot of the checkout tab of the HikaShop configuration so that we could see how you configured your checkout.
What you're describing indicates some kind of zone restriction being enforced.
For example, you don't have shipping methods configured for the countries in the EU but you do for countries outside the EU.
Or it could be the same with the zone restriction of payment methods.
But that's just the most simple causes I can think of. So you can already check these, but otherwise, we would need more information to be able to have a better picture of the situation and provide a solution.

Please Log in or Create an account to join the conversation.

  • Posts: 117
  • Thank you received: 2
  • Hikashop Business
2 months 3 weeks ago #299499

Hi Nicolas

First off, sorry for the late reply.

The reason we didn't provide a link is because we are experiencing these issues on our test server which is at the moment only accessible internally, however we can patch you through should this be required. As for the screenshots of the configuration is simply me forgetting. (Fixed now, see attached image).

We have shipping method configured for all of our countries / same goes for payment, or rather, we don't have any restrictions regarding country, the only thing is whether the customer is paying in EU or USD. (So purely tax / vat related).

I had the same idea as you though and have tried practically every setting to see if it made a difference, alas to no avail.

Attachments:
Last Edit: 2 months 3 weeks ago by earmaster.

Please Log in or Create an account to join the conversation.

  • Posts: 117
  • Thank you received: 2
  • Hikashop Business
1 month 3 weeks ago #300976

Hi Nicolas

Has there been any progress / updates on this? Even with Hikashop 4.0.1 do we experience this issue, although with a added error of:

PHP Notice: Undefined index: shipping_address in /administrator/components/com_hikashop/classes/user.php on line 463, referer: http://xxxxx/shop/checkout.html

Although with it just being a notice I'm uncertain whether this is something that affects us being unable to finalize a order.

Please Log in or Create an account to join the conversation.

  • Posts: 23199
  • Thank you received: 3592
  • MODERATOR
1 month 3 weeks ago #300986

Hello,

I'm sorry. I don't know why but the thread was marked as "resolved".
Regarding your checkout workflow, you do not have any way to create shipping address for your customer.
But you have the shipping method block, so it means that you require a shipping method ; it could be problematic.

Now regarding the notice. It is just a notice. As you suspected, it's not a blocking issue.
But the fact that you're requesting a shipping but not having a way to set-up the shipping address, is problematic.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 117
  • Thank you received: 2
  • Hikashop Business
1 month 1 week ago #301244

Hi Jerome

I've removed the Shippping part from the checkout but the problem stil persist.

I've tried with (almost) every setting turned on / off in nearly every combination but nothing seems to have worked.

Last Edit: 1 month 1 week ago by earmaster.

Please Log in or Create an account to join the conversation.

  • Posts: 64471
  • Thank you received: 9312
  • MODERATOR
1 month 1 week ago #301273

Hi,

Normally, you should have an error message which indicates what is the problem.
If you don't, try again after activating the default template of Joomla and activating the "error reporting" and "debug mode" of the Joomla configuration.
You should hopefully get more information that way.
Also, if you could provide a screenshot of the page before you click on the "finish" button of the checkout and a similar screenshot of the page after, that would help us understand the situation.

Please Log in or Create an account to join the conversation.

Time to create page: 0.091 seconds
Powered by Kunena Forum