Add coupon code to checkout goes to blank white screen

  • Posts: 215
  • Thank you received: 2
  • Hikashop Multisite
8 months 2 days ago #282803

-- url of the page with the problem -- : www.restorationuk.com/checkout/checkout/task-step/step-1
-- HikaShop version -- : 3.2.0
-- Joomla version -- : 3.8.2
-- PHP version -- : 5.6.31
-- Browser(s) name and version -- : Chrome

Hello,
When entering a coupon code into the checkout it refreshes as a white screen. I have set the error reporting to Maximum and Development but I receive no errors. How can I resolve this issue?

Thanks Phil

Please Log in or Create an account to join the conversation.

  • Posts: 215
  • Thank you received: 2
  • Hikashop Multisite
8 months 2 days ago #282828

Hello,
I updated Hikashop on the staging site ( staging1.restorationuk.com ) to the latest version 3.2.1. However that didn't fix the issue, but I read somewhere turning legacy mode off might fix it.
I did that and the white screen doesn't appear now however when adding the coupon it just refreshes the page and doesn't add the discount to the cart.

I tried adding a incorrect coupon but no error messages appear. I just reloads the page.

Thanks

Last Edit: 8 months 2 days ago by dancingkazzaf.

Please Log in or Create an account to join the conversation.

  • Posts: 62780
  • Thank you received: 9006
  • MODERATOR
8 months 1 day ago #282806

Hi,

If you don't see the error message even though you activated the "error reporting" AND the "debug mode" settings of the Joomla configuration, then you need to look into the PHP error log of your server for the error message.
Once you have the error message it will be easy to find the source of the issue, but without it, it's hard to say anything. One thing you could try is turn off the "checkout legacy" setting of the HikaShop configuration in order to use the new checkout system. That might help. Also, if you have third party extensions like AWOCoupon, make sure that you have a recent version.

Please Log in or Create an account to join the conversation.

  • Posts: 215
  • Thank you received: 2
  • Hikashop Multisite
8 months 1 day ago #282863

I am using the standard hikashop coupon system. I tried turning legacy mode off makes no difference. I have checked the logs and I cant see anything relating to the coupon. I get a warning error in the console when I press add on the coupon button. Not sure what it means.
I have attached both below:

I have just come across this error message on the checkout
Notice: Undefined property: Joomla\CMS\Document\HtmlDocument::$base in /home/restorationuk/public_html/libraries/src/Document/Document.php on line 948

and this when adding a coupon
Fatal error: Call to undefined method hikashopCartClass::loadCart() in /home/restorationuk/public_html/plugins/hikashop/awocoupon/awocoupon.php on line 72

Attachments:
Last Edit: 8 months 1 day ago by dancingkazzaf.

Please Log in or Create an account to join the conversation.

  • Posts: 62780
  • Thank you received: 9006
  • MODERATOR
8 months 1 day ago #282869

Hi,

As expected, it comes from the awocoupon plugin.
If you're using the HikaShop standard coupon system, then there is no point in keeping that awocoupon plugin activated. Please deactivate and/or uninstall it and that will remove the error you have.

Please Log in or Create an account to join the conversation.

  • Posts: 215
  • Thank you received: 2
  • Hikashop Multisite
7 months 3 weeks ago #283335

Hello,
Thanks for your help. I didn't realise I had already installed Awocoupon on the site. However I updated the plugin and everything started working fine.

Thanks Again

Please Log in or Create an account to join the conversation.

Time to create page: 0.090 seconds
Powered by Kunena Forum