Many things broken since 3.0.0 upgrade

  • Posts: 21
  • Thank you received: 0
1 year 9 months ago #259865

-- HikaShop version -- : 3.0.0
-- Joomla version -- : 3.6.5
-- PHP version -- : 5.5.38
-- Browser(s) name and version -- : All
-- Error-message(debug-mod must be tuned on) -- : Many things broken since 3.0.0 upgrade and installation of hikamarket, auction, and serial. I am willing to pay for help to get this up and operational ASAP.

Many things broken since 3.0.0 upgrade and installation of hikamarket, auction, and serial. I am willing to pay for help to get this up and operational ASAP.

Can you please drop me some details on how I can acquire help on the integration? I was running 2.6 business before the upgrade and i am going to have to roll back my site if I do not get some sort of help fixing it. I can no longer checkout die to issues with shipping methods, The coupon button is not working, any item with a variant will not add to cart after a variant is selected, purchasing a won auction item does not get added to cart, and many many more things. I have tried to do initial troubleshooting with debugging, but I am right in the middle of some pressing work. Please get back to me ASAP.

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
1 year 9 months ago #259866

On a side note, I am also interested in making certain purchased items appear in the user info such as you have here with the kunena forum. Is there any source for that or a plugin?

Please Log in or Create an account to join the conversation.

  • Posts: 843
  • Thank you received: 66
1 year 9 months ago #259867

Hi,

If you did it on the live site I suggest you to roll back if you have a back up. Then install update on your demo/test site and check how it works. By my self I have noticed that I will have to check code in some of the view files and make my template work with new update. There is a lot of changes with new hikashop version and if you have many view overrides updating it on a live site would be drastic thing. Hope that helps...

Many thanks

The following user(s) said Thank You: Jerome

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
1 year 9 months ago #259869

It was on a live site and I am always prepared to roll back, but it would be a lot of trouble right now. I am really hoping I can get a dev on board with getting it up and running. It is not just the look and feel of my shop, but the core functionality that has been effected. There are so many issues that I really cannot begin to troubleshoot. As far as I know my db structure is good to go. I am thinking maybe some JS conflicts, but there are absolutely no errors using developer tools in chrome. I have not been through all of the debugging but I cannot imagine I will be able to get it up and running in a reasonable amount of time. Do you have any idea when the dev's actually show up?

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
1 year 9 months ago #259870

@kyratn do you happen to have a copy of a previous stable release I could possibly roll back to? I am willing to try and blow it away and do an install of business again.

Please Log in or Create an account to join the conversation.

  • Posts: 22878
  • Thank you received: 3551
  • MODERATOR
1 year 9 months ago #259879

Hi,

I saw that you also have contact the support team by email about your problem.
Please try to not duplicate your message between the forum and the "contact us" ; unfortunately, it won't make our support faster (but will have the opposite effect due to the augmentation of the message we have to handle).

Please indicates which HikaMarket, HikaSerial and HikaAuction version number you're using.
Please note that HikaAuction 2.0 has been released in the same time than HikaShop 3.0 in order to provide support of the new features.

If you can also provide some details about your current configuration (specially the "Advanced / Legacy" settings) and details about the issues and how to reproduce them ; it will help the support team to help you.

HikaShop 3.0 has been released yesterday and is not yet distribute in "auto updates".
The update of a production website is for sure not recommended without any validation on a test or pre-production website.
Like we do not recommend to perform an update without making a full backup just before.

You will find details about the legacy mode of HikaShop 3.0 here :
www.hikashop.com/blog/367-hikashop-3-0-out.html#legacy

And details about the release of HikaAuction 2.0 here :
www.hikashop.com/blog/366-hikaauction-2-0.html

For sure, restoring a backup or installing back the previous version of HikaShop you had would be, right now, the best solution.
So you will be able to time your time for the test and the validate of the update on a pre-production website.

For your latest point ; the Kunena integration with have here is not directly with HikaShop but with our custom made license component.
Thanks to the Kunena triggers it is possible to extend the profile and his badges ; afterwards it would require a custom plugin development and some "rules" in order to know what you want to display exactly.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
1 year 9 months ago #259889

Hey, thanks for the reply... I am not trying to cause confusion or rush things. I just do not know which side of the house I need to contact for some special case help. That being said, is there any way I can proceed with one of the developers just getting my current setup working? I upgraded to 3 as it said it was the latest stable release in my subscriptions. I also just two days ago purchased the other three components so they are the latest. I can do a restore, but I really do not want to go that route, I want to push forward with this because I had pre-maturely made plans for each of the components I purchased. Again, I am not one of those who posts in random places seeking for help, I just sent an email and made a forum post to get help from two different sides of the house.

Please Log in or Create an account to join the conversation.

  • Posts: 1882
  • Thank you received: 255
  • MODERATOR
1 year 8 months ago #259914

Hello,

Jerome advice you to go back because for now hard to tell how long solve your issue will take...

It's more hard to tell if you don't give more elements like Jerome asked for...

"Please indicates which HikaMarket, HikaSerial and HikaAuction version number you're using."

"If you can also provide some details about your current configuration (specially the "Advanced / Legacy" settings) and details about the issues and how to reproduce them ; it will help the support team to help you."


Right now impossible to understand what happen, we just know that you have issues.
We expecting more element in order to help you.

Regards

Last Edit: 1 year 8 months ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
1 year 8 months ago #259942

I inadvertently just stated the versions I'm using are the newest as I JUST purchased them days ago. The reason the shop is broken is due to the 3.0.0 upgrade. In multiple comments above I state a few issues but also say I'm interested in live support. Is this something your team can help me with?

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
1 year 8 months ago #259951

HikaAuction v2.0.0
HikaMarket MV v1.7.2
HikaSerial v1.10.4
Hikashop Business v3.0.0
!Joomla v3.6.5
PHP v5.5.38

ISSUES:
During checkout I get these errors:
Notice: Undefined property: stdClass::$weight in /administrator/components/com_hikashop/helpers/helper.php on line 2505
Notice: Undefined property: stdClass::$weight in /administrator/components/com_hikashop/helpers/helper.php on line 2505
Notice: Undefined property: stdClass::$weight in /administrator/components/com_hikashop/helpers/helper.php on line 2513
Notice: Undefined property: stdClass::$weight in /administrator/components/com_hikashop/helpers/helper.php on line 2514

I doubt this is a real issue, and yes the item does have a weight defined. The real issue starts happening when I click my shipping method which is one using the USPS API shipping method. It will continue on to the next stage which is payment method. Upon clicking the payment method it takes me back to the shipping stage and asks me to choose shipping.

I have a product with 2 variants, if I leave the default variant and click add to cart it will add it to the cart, but if I choose the other variant it will just take me to the cart page without adding the item.

When placing a bid on an auction item I cannot click the bid button and submit the bid. I can however hit return to place a bid. The bid is visible to me, but if another user places a bid, it is updated in bid history, but does not update the minimum bid amount.



Hopefully this is enough to get a bit of insight? Please let me know if you require more information.

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
1 year 8 months ago #259954

I have changed my settings to NOT use legacy as of now. I am now getting a bit of feedback from a new popup. The aforementioned issue with the variants now instead of taking me to an empty cart will pop up a message saying there is not enough stock. I have quantities in each variant and have tried unlimited as well as exact amount of stock in the main product. The quantities are correctly displayed on the product page.

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
1 year 8 months ago #259955

I have also disabled using bootstrap from advanced configurations. I have noticed when trying to select a shipping method and clicking next it acts as though the page refreshes. However, if I do not select a shipping method and click next it will continue through checkout. after I get to the end of checkout it simply redirects me to my home page. There is nothing left in my cart and the order status is still just set to created.

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
1 year 8 months ago #259956

After turning legacy modes back on and Use AJAX when possible for add to cart buttons set to NO, I can make it passed the shipping method, but when I get to the end of checkout it will kick me back to the shipping method asking me to please choose an option.

I also created a new manual shipping method to test and the result is the same.

Last Edit: 1 year 8 months ago by thagh05t.

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
1 year 8 months ago #259967

I should also add that I have disabled everything but HikaShop Business on the site so I can get the core functionality working before I continue.

Please Log in or Create an account to join the conversation.

  • Posts: 22878
  • Thank you received: 3551
  • MODERATOR
1 year 8 months ago #259953

Hi,

Please re-download HikaShop 3.0 in order to get the latest patches about the cart weight.
That issue has been fixed yesterday night by Mohamed.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
1 year 8 months ago #260150

Update fixed the error as expected, but I am still having all other issues. Can I please purchase some level of support So I can proceed with this wonderfully crafted upgrade?

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
1 year 8 months ago #260152

Got this error when going through checkout.

step-4:76 Uncaught ReferenceError: hkjQuery is not defined
at HTMLDocument.<anonymous> (step-4:76)
at i (jquery.min.js:2)
at Object.fireWith [as resolveWith] (jquery.min.js:2)
at Function.ready (jquery.min.js:2)
at HTMLDocument.K (jquery.min.js:2)
(anonymous) @ step-4:76
i @ jquery.min.js:2
fireWith @ jquery.min.js:2
ready @ jquery.min.js:2
K @ jquery.min.js:2

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
1 year 8 months ago #260156

I have disabled a Module that now lets me at least select my shipping method and move forward through the checkout process, but on the final step, shipping does not show up in the totals and when checking out through PayPal there is no shipping fee added to the totals either. Please help....

Please Log in or Create an account to join the conversation.

  • Posts: 21
  • Thank you received: 0
1 year 8 months ago #260162

Can I please at least have the install for the previous version of hikashop business so I can downgrade?

Please Log in or Create an account to join the conversation.

  • Posts: 22878
  • Thank you received: 3551
  • MODERATOR
1 year 8 months ago #260165

Hi,

1 - Would it be possible to have more details about your configuration (shipping settings, shipping methods) and the content of your cart in order to understand and reproduce your issue (in your website and in our test local website) ?

2 - For such kind of request, please use the "contact us" form.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

Time to create page: 0.140 seconds
Powered by Kunena Forum