Modules showing on child pages despite using Advanced Module Manager

  • Posts: 66
  • Thank you received: 1
  • Hikashop Business
1 year 5 months ago #260764

-- HikaShop version -- : 3.0.0
-- Joomla version -- : 5.6.5
-- PHP version -- : 7.0.0

Hi
It was suggested that I use advanced module manager from Regular Labs to ensure that some modules would only show up on specific pages. In my case that's the home page (categories listing.

However, that is not working. I suspect that it requires a bit of coordination between hikashop and regular labs to solve this. Apparently, it works fine with eralier versions of hikashop, but not now.

Compare home page with this empty category
Regards

Please Log in or Create an account to join the conversation.

  • Posts: 62779
  • Thank you received: 9005
  • MODERATOR
1 year 5 months ago #260766

Hi,

We didn't change anything regarding the module display because HikaShop 2.6.4 and the 3.0.0 and as far as we know, Advanced Modules Manager works perfectly fine with the 2.6.4, so I suspect it should be the same with the 3.0.0 without the need for any modification on either parts.
Did the problem occured after the update of HikaShop ? I suspect it doesn't come from the update but it just an issue with how the module is configured. And without knowing more on that we won't be able to say much in that case.

Please Log in or Create an account to join the conversation.

  • Posts: 66
  • Thank you received: 1
  • Hikashop Business
1 year 5 months ago #260842

Hi
I've raised this with Regular Labs.
The state of play can be read here
I have also raised it with the Gantry team here , as I am using a gantry template. Perhaps it needs a concerted effort, as I know there are a lot sites using this combination of programmes.

Please Log in or Create an account to join the conversation.

  • Posts: 66
  • Thank you received: 1
  • Hikashop Business
1 year 5 months ago #260845

Hi again

Peter suggested that I try a module position in Gantry, rather than a module instance. Lo and behold: it worked!

regards
David

Please Log in or Create an account to join the conversation.

Time to create page: 0.113 seconds
Powered by Kunena Forum