Skip to main content

2.1.3 to 2.2 upgrade

More
13 years 1 month ago #117307 by nlthein
2.1.3 to 2.2 upgrade was created by nlthein
-- url of the page with the problem -- : mywebsite.com/mypage
-- HikaShop version -- : 2.1.3
-- Joomla version -- : 3.1.5
-- PHP version -- : x.x.x
-- Browser(s) name and version -- : firefox
-- Error-message(debug-mod must be tuned on) -- :
An error has occurred.

-1 Copy file failed


After upgrade form 2.1.3 to 2.2 ... I have "-1 Copy file failed" and unable to update it.

Also Australia post shipping method is stuck at the express post and standard post selection.

Let me know where do I have to check?

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago #117315 by Mohamed Thelji
Replied by Mohamed Thelji on topic 2.1.3 to 2.2 upgrade
Hi,

Ok, so can you download the last version of Hikashop through our website, install it, and test it again ?

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago #117316 by nicolas
Replied by nicolas on topic 2.1.3 to 2.2 upgrade
This is an access right issue which prevents joomla from copying the files.
An install via FTP as explained here should probably circumvent the problem:
www.hikashop.com/support/support/documen...-to-install.html#ftp

Regarding your checkout, It's potentially your payment methods which are not configured properly. Please check that FAQ if you don't see any on your checkout:
www.hikashop.com/support/faq.html#paym

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago #117324 by nlthein
Replied by nlthein on topic 2.1.3 to 2.2 upgrade
hi still the same ... no different between download 30 min ago and installed and just download/upgraded right now.
same error
-1 Copy file failed
btw, australia post shipping method wasn't working since 2.1.3. That's a reason i've tried to upgrade

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago - 13 years 1 month ago #117328 by Mohamed Thelji
Replied by Mohamed Thelji on topic 2.1.3 to 2.2 upgrade
Ok,
I think that you'll probably find more information through the documentation , can you follow each step of the "-1 - an error has occurred ( It was not possible to copy the selected file. )" section and tell me if it solved your problem ?

Regarding the AUPOST shipping method, it will maybe fix your issue to update, if not I'll just help you to solve your problem :).
Last edit: 13 years 1 month ago by Mohamed Thelji.

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago - 13 years 1 month ago #117338 by nlthein
Replied by nlthein on topic 2.1.3 to 2.2 upgrade
still the same after using ftp method


didn't find these line in the folder.php file as well .................

Around line 93 AND 122, please replace:

return JError::raiseError(-1, JText::_('Copy failed'));

by

return JError::raiseError(-1, JText::_('Copy failed').' '.$sfid.' => '.$dfid);
Last edit: 13 years 1 month ago by nlthein.

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago #117490 by Mohamed Thelji
Replied by Mohamed Thelji on topic 2.1.3 to 2.2 upgrade
Ok, another solution would be to rename these folders :
- "Hikashop\administrator\components\com_hikashop"
- "Hikashop\components\com_hikashop"

And install Hikashop again.

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago #117498 by nlthein
Replied by nlthein on topic 2.1.3 to 2.2 upgrade
do you mean rename this one "Hikashop\administrator\components\com_hikashop" to the following


- "Hikashop\components\com_hikashop"

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago #117502 by Mohamed Thelji
Replied by Mohamed Thelji on topic 2.1.3 to 2.2 upgrade
No, I just meant to rename this folders :
- "Your website\administrator\components\com_hikashop"
by :
- "Your website\administrator\components\com_hikashop_old"

And this folder :
- "Your website\components\com_hikashop"
By :
- "Your website\components\com_hikashop_old"

And then Install Hikasop again.

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago #117506 by nlthein
Replied by nlthein on topic 2.1.3 to 2.2 upgrade
Hi Mohamed,

After rename as per you suggestion, I've tried to install FTP as well as .ZIP unfortunately both failed.

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago #117508 by Mohamed Thelji
Replied by Mohamed Thelji on topic 2.1.3 to 2.2 upgrade
Ok so can you send us a temporary back-end and ftp access through the contact form ? then we'll try to install it ourselves ? :)

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago #117513 by nlthein
Replied by nlthein on topic 2.1.3 to 2.2 upgrade
Thanks Mohamed.

Already sent it to you via contact form. Let me know if you have any problem with it. Cheers!

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago - 13 years 1 month ago #117556 by Mohamed Thelji
Replied by Mohamed Thelji on topic 2.1.3 to 2.2 upgrade
I tried to install Hikashop through your website and found that the problem is coming from access rights to some files on your "/media/com_hikashop/images" folder for example. I tried to change their access rights but I couldn't do it because there is a different file's owner named "0 0".
So the best solution will be ask your hosting company to fix this access right issue.
Last edit: 13 years 1 month ago by Mohamed Thelji.

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago #117591 by nlthein
Replied by nlthein on topic 2.1.3 to 2.2 upgrade
Hi Mohamed,

I've already changed the permission and got the following error when I tried to install ..

0 SQL=ALTER TABLE `jos_hikashop_payment` ADD `payment_ordering` int(10) unsigned NOT NULL DEFAULT '0', ADD `payment_published` tinyint(4) NOT NULL DEFAULT '1';

Thanks for your help.

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago #117672 by Mohamed Thelji
Replied by Mohamed Thelji on topic 2.1.3 to 2.2 upgrade
You have changed the file's owner, so I changed the file's permissions myself and successfully installed the last version of Hikashop.

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago #117675 by nlthein
Replied by nlthein on topic 2.1.3 to 2.2 upgrade
:P
Thank you, Mohamed. Appreciate your help!

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago #117676 by nlthein
Replied by nlthein on topic 2.1.3 to 2.2 upgrade
When I tested the checkout, I have the following error ..........
================================
0 - SQL=SELECT * FROM jos_hikashop_massaction WHERE massaction_published=1 && massaction_triggers!=''

You may not be able to visit this page because of:

an out-of-date bookmark/favourite
a search engine that has an out-of-date listing for this site
a mistyped address
you have no access to this page
The requested resource was not found.
An error has occurred while processing your request.

Please try one of the following pages:

Home Page

If difficulties persist, please contact the System Administrator of this site and report the error below..

SQL=SELECT * FROM jos_hikashop_massaction WHERE massaction_published=1 && massaction_triggers!=''
================================

When I choose "Add to cart", I have 404 - Page not found : notice.

Could you please help me as well?

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago - 13 years 1 month ago #117684 by Mohamed Thelji
Replied by Mohamed Thelji on topic 2.1.3 to 2.2 upgrade
Ok, I think that an SQL request like this through your PHPmyadmin page will probably do the job :
Code:
CREATE TABLE IF NOT EXISTS `#__hikashop_massaction` ( `massaction_id` int(10) unsigned NOT NULL AUTO_INCREMENT, `massaction_name` varchar(255) NOT NULL DEFAULT '', `massaction_description` text NOT NULL, `massaction_table` varchar(255) NOT NULL DEFAULT 'product', `massaction_published` tinyint(4) NOT NULL DEFAULT '1', `massaction_lasttime` int(10) unsigned NOT NULL DEFAULT '0', `massaction_triggers` text NOT NULL, `massaction_filters` text NOT NULL, `massaction_actions` text NOT NULL, `massaction_report` text NOT NULL, PRIMARY KEY (`massaction_id`), KEY `massaction_table` (`massaction_table`) )
Don't forget to replace "#_" by your database prefix.
Last edit: 13 years 1 month ago by Mohamed Thelji.

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago #117698 by nlthein
Replied by nlthein on topic 2.1.3 to 2.2 upgrade
Got the following SQL error after fix applied ..

0 - SQL=INSERT IGNORE INTO `jos_hikashop_order` ( `order_user_id`,`order_status`,`order_shipping_address_id`,`order_billing_address_id`,`order_currency_id`,`order_type`,`order_full_price`,`order_tax_info`,`order_shipping_price`,`order_shipping_tax`,`order_shipping_params`,`order_payment_price`,`order_discount_tax`,`order_discount_price`,`order_shipping_id`,`order_shipping_method`,`order_payment_id`,`order_payment_method`,`order_created`,`order_ip`,`order_modified` ) VALUES ( '1','created','2','2','6','sale','149.95','a:1:{s:3:\"GST\";O:8:\"stdClass\":4:{s:11:\"tax_namekey\";s:3:\"GST\";s:8:\"tax_rate\";s:7:\"0.10000\";s:10:\"tax_amount\";d:13.63181818181818272250893642194569110870361328125;s:23:\"tax_amount_for_shipping\";d:0.63181818181818183433051672182045876979827880859375;}}','6.95','0.63181818181818','O:8:\"stdClass\":1:{s:6:\"prices\";a:1:{s:3:\"1-4\";O:8:\"stdClass\":3:{s:14:\"price_with_tax\";d:6.949999999999999289457264239899814128875732421875;s:3:\"tax\";d:0.63181818181818183433051672182045876979827880859375;s:5:\"taxes\";a:1:{s:3:\"GST\";N;}}}}','0','0','0','1-4','aupost','2','paypal','1375881672','124.149.174.222','1375881672' )

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago #117705 by Mohamed Thelji
Replied by Mohamed Thelji on topic 2.1.3 to 2.2 upgrade
Ok, I think that following this documentation will probably help you.

Please Log in or Create an account to join the conversation.

Time to create page: 0.409 seconds
Powered by Kunena Forum