error in back end hikashop after updating to 4.0.1

  • Posts: 11
  • Thank you received: 1
1 month 2 weeks ago #301137

-- url of the page with the problem -- : www.oorsuizen.net
-- HikaShop version -- : 4.01
-- Joomla version -- : 3.9.1
-- PHP version -- : 7.1.14
-- Browser(s) name and version -- : firefox 63.0.3 (64-bit)
-- Error-message(debug-mod must be tuned on) -- : Warning: implode(): Invalid arguments passed in ... /administrator/components/com_hikashop/classes/widget.php on line 711

I just updated to hikashop 4.0.1 but now I get 2x the same error message in the back end of hikashop.
Warning: implode(): Invalid arguments passed in /administrator/components/com_hikashop/classes/widget.php on line 711

Please Log in or Create an account to join the conversation.

  • Posts: 23199
  • Thank you received: 3592
  • MODERATOR
1 month 2 weeks ago #301139

Hello,

HikaShop 4.0.1 received some hot fixes for the widget part.
Would it be possible to know your build number version ?
CF : www.hikashop.com/support/documentation/5...onfig.html#main_main

Please note that warning are not errors ; they do not create direct issues and warning messages should not be displayed in a production environment (for various reasons, including security purpose).

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 1
1 month 2 weeks ago #301162

version: HikaShop Starter 4.0.1 [1811301551]

These messages are displayed in the production environment e.g. dashboard.

Please Log in or Create an account to join the conversation.

  • Posts: 64471
  • Thank you received: 9312
  • MODERATOR
1 month 2 weeks ago #301172

Hi,

What Jerome said meant that on a production environment, you should turn off the "error reporting" setting of the Joomla configuration and thus you should not see that warning.

Download again the install package on our website and install it on yours. That will add the patch for that warning.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 1
1 month 2 weeks ago #301213

The debug system was set to no when this occurred.

Please Log in or Create an account to join the conversation.

  • Posts: 23199
  • Thank you received: 3592
  • MODERATOR
1 month 1 week ago #301217

Hello,

Joomla debug mode is not the same thing that displaying PHP notices in the generated pages.
In Joomla you can see to override that PHP setting ; but best to let your web hosting dealing with that and not force the display of PHP messages, for your own safety.
Please don't hesitate to contact your web hosting for that and to perform some search on Internet to help you with the configuration of your Joomla website.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 11
  • Thank you received: 1
1 month 1 week ago #301248

Thanks. I see: global configuration - server - error reporting: now set to none. Now no messages anymore. Was set on system default. But in former versions this has never occurred.

Please Log in or Create an account to join the conversation.

Time to create page: 0.089 seconds
Powered by Kunena Forum