Calculating no VAT with EU VAT number

  • Posts: 219
  • Thank you received: 4
  • Hikashop Business
2 years 10 months ago #219094

-- url of the page with the problem -- : www.modusystem.nl
-- HikaShop version -- : 2.6.0
-- Joomla version -- : 3.4.5
-- PHP version -- : 5.6
-- Browser(s) name and version -- : all
-- Error-message(debug-mod must be tuned on) -- : TAX problem

For sure I'm doing something wrong.


I want no VAT if a customer add a VAT number

CONFIGURATION:
VAT TAX zone Europe
VATnumber controle Online controle




TAXES:
1 BTW hoog BTW hoog (EU) (0%) Zone: Europe Klant type: Company with VAT nummer

2 BTW hoog BTW hoog (21%) Zone: Europe Klant type: Company without VAT-nummer

3 BTW hoog BTW hoog (21%) Zone: Europe



Jan

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 63328
  • Thank you received: 9128
  • MODERATOR
2 years 10 months ago #219119

Hi,

I see several potential problems:
1. Make sure that the "default client type" setting of the HikaShop configuration is set to "individuals"
2. You can delete your first tax rule as it is not necessary.
3. in your third tax rule, you want to restrict the type of client to "individuals" as well.

Please Log in or Create an account to join the conversation.

  • Posts: 219
  • Thank you received: 4
  • Hikashop Business
2 years 10 months ago #219149

Hi Nicolas,

Thanks for your answer.

It's working now!

Jan

Please Log in or Create an account to join the conversation.

  • Posts: 219
  • Thank you received: 4
  • Hikashop Business
2 years 10 months ago #219151

Hmmmm. Almost :-)

When I'm in The Netherlands and ordering with my own Dutch VAT ID the Hikashop is not adding VAT.
Hikashop has to calculate me VAT.

Jan

Please Log in or Create an account to join the conversation.

  • Posts: 63328
  • Thank you received: 9128
  • MODERATOR
2 years 10 months ago #219178

That's normal. You didn't create tax rules for the netherlands.
If you want to tax everyone in the netherlands, you want to add a new tax rule for the netherlands only.
And you also want to remove the ntherlands for the Europe tax zone's sub zones listing.

The following user(s) said Thank You: janvankuijk

Please Log in or Create an account to join the conversation.

  • Posts: 219
  • Thank you received: 4
  • Hikashop Business
2 years 10 months ago #219223

It's working now!

Thanks a lot!!
Jan

Please Log in or Create an account to join the conversation.

  • Posts: 111
  • Thank you received: 4
1 year 3 months ago #272352

1. Make sure that the "default client type" setting of the HikaShop configuration is set to "individuals"

How? I did not find any hint in the docs. Thanks

Please Log in or Create an account to join the conversation.

  • Posts: 22799
  • Thank you received: 3543
  • MODERATOR
1 year 3 months ago #272357

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 111
  • Thank you received: 4
1 year 3 months ago #272421

Thanks, but non of these pages contain "default client type".

Please Log in or Create an account to join the conversation.

  • Posts: 63328
  • Thank you received: 9128
  • MODERATOR
1 year 3 months ago #272427

Hi,

That settings has been removed a few years ago as people were mistakenly changing it. So there is no need to check that setting. Your problem can't come from it.

Please Log in or Create an account to join the conversation.

Time to create page: 0.106 seconds
Powered by Kunena Forum