VAT & Coupon - Price not correct

  • Posts: 149
  • Thank you received: 4
4 months 4 weeks ago #283094

-- HikaShop version -- : 2.6.1
-- Joomla version -- : 3.7.5
-- PHP version -- : 5.6.30
-- Browser(s) name and version -- : Firefox 57.0

Hi hikashop-Team,

we have a Problem with the VAT and a coupon.

We have set the "Apply discounts" on after taxation . However, the dicount will be deducted from the net price in the cart. Does this attitude only apply to discounts and not for coupons? I also checked override plugins.

Can you help me with this?

Please Log in or Create an account to join the conversation.

  • Posts: 1639
  • Thank you received: 237
  • MODERATOR
4 months 4 weeks ago #283097

Hello,

To quickly answer your question the Apply discounts option impact Coupon as well.
Now, to better understand your issue can you provide :
- Coupon configuration page screenshot
- Taxes main configuration settings (in Main tab HikaShop Configuration)
- As example, a Cart results (with and without coupon) screenshot
- Tax rate apply on your product(s)

Awaiting news from you.

Regards

Last Edit: 4 months 4 weeks ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 4
4 months 3 weeks ago #283298

Hallo,

thanks for the fast reply.

Below are the screenshots:

Settings coupon:




Taxes main configuration:


Cart result without coupon:


Cart result with coupon:


Tax rate in Germany is 19%.

I hope this helps. Thanks in advance.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 1639
  • Thank you received: 237
  • MODERATOR
4 months 3 weeks ago #283310

Hello,

Thanks to your elements, I process several calculation and you right it's seems that their something that went wrong.
Unfortunately I'm unable to understand from where come the error... And your settings seems corrects.
But you have to know that we add several improvement specific on Total cart calculation.
And so, can you try to update on a clone/test website in order to see if that solve your issue.

Awaiting news from you.

Regards

Last Edit: 4 months 3 weeks ago by Philip.
The following user(s) said Thank You: olivnewton

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 4
4 months 3 weeks ago #283495

I updated hikashop to 3.2.1. and now it works!

Thanks Phillip
Have a good time.

The following user(s) said Thank You: Philip

Please Log in or Create an account to join the conversation.

Time to create page: 0.089 seconds
Powered by Kunena Forum