Wrong message comments "thanks for your vote"

  • Posts: 113
  • Thank you received: 2
1 year 7 months ago #254171

-- HikaShop version -- : 2.6.4

hello,

I searched this problem on the forum but I have not found an answer.
 
When a user comments a product appears a message "Thanks for your vote", but the correct message is "thank you for your comment". It is not an override problem, because I tried to delete the translation and the wrong message persists.

In System> global configuration> functionality> vote & comment I have these settings:


This is a screenshot of the language files.

So, when someone comments, should get out the message about:
THANKS_FOR_COMMENT
and not
THANK_FOR_VOTE
Thanks for your help!

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 62433
  • Thank you received: 8927
  • MODERATOR
1 year 7 months ago #254201

Hi,

Try changing the code:

$this->error = array('code' => '2', 'message' => JText::_('THANK_FOR_VOTE'));
to:
$			if(!empty($element->vote_comment)){
				$this->error = array('code' => '2', 'message' => JText::_('THANKS_FOR_COMMENT'));
			}else{
				$this->error = array('code' => '2', 'message' => JText::_('THANK_FOR_VOTE'));
			}
in the file administrator/components/com_hikashop/classes/vote.php
That should fix the problem.

Please Log in or Create an account to join the conversation.

  • Posts: 113
  • Thank you received: 2
1 year 7 months ago #254256

Nicolas hello, thanks for the reply.

Here's how it becomes the page after changing the code.



there is an error in the code, or it conflicts with something?

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 62433
  • Thank you received: 8927
  • MODERATOR
1 year 7 months ago #254258

Hi,

There is a typo in my previous message. At the beginning of the second code section, there is a $ symbol all alone which shouldn't be there.
Remove it and it should help.

Please Log in or Create an account to join the conversation.

  • Posts: 113
  • Thank you received: 2
1 year 7 months ago #254309

Hello Nicolas,

even that works. Same problem.

Please Log in or Create an account to join the conversation.

  • Posts: 62433
  • Thank you received: 8927
  • MODERATOR
1 year 7 months ago #254314

Hi,

Then please turn on the "error reporting" of the Joomla configuration and provide the error message that you have on your product page, as well as a screenshot of the code where you did the modification.

Please Log in or Create an account to join the conversation.

  • Posts: 113
  • Thank you received: 2
1 year 7 months ago #254397

ok, I solved by turning off the plugin jch optimize and clearing cache

Please Log in or Create an account to join the conversation.

Time to create page: 0.091 seconds
Powered by Kunena Forum