Possible bug - wishlist

  • Posts: 50
  • Thank you received: 2
  • Hikashop Business
1 year 1 month ago #278658

-- HikaShop version -- : 3.2.0
-- Joomla version -- : 3.7.5
-- PHP version -- : 7.0
-- Browser(s) name and version -- : Chrome 61

In the comparison page I see Add to wishlist buttons altough Wishlist option is globally disabled in Configuration->Functions->Main

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 11842
  • Thank you received: 1635
  • MODERATOR
1 year 1 month ago #278659

Hello,

Can you check if you have properly disabled the "Enable the wishlists" option through the page "Hikashop->System->Configuration->Features" and see if the Wishlist button is still displaying ?

I just tested it on my end and it worked fine.

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 2
  • Hikashop Business
1 year 1 month ago #278696

Yes, it's disabled, I attach the screen from my options.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 1882
  • Thank you received: 255
  • MODERATOR
1 year 1 month ago #278707

Hello,

Can you enter your backend in english language in order to better understand your backend configuration.
Nevertheless, I try to reproduce your configuration (from what we know) and was unable to have the same result.
Can you provide an Url link in order to process some tests and see the issue by ourself ?

Awaiting news from you.

Regards

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 2
  • Hikashop Business
1 year 4 weeks ago #278822

OK, I attach the screenshot in english. I will send you right now the link via PM.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 63584
  • Thank you received: 9158
  • MODERATOR
1 year 4 weeks ago #278857

Hi,

I see the problem, however, I don't have it on my end. Please switch to the default template of Joomla and check if you have the issue. If you don't, then it comes from an old view override you have.

PS : When sending private content ; you have to use the "contact us" form and not use private message. Unfortunately the private message do not allow the support team to work as a team

Last Edit: 1 year 4 weeks ago by nicolas.

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 2
  • Hikashop Business
1 year 3 weeks ago #278905

I switched to protostar and the button is still there. Prostar has no overrides for Hikashop, so the bug really exists. I attach the screen.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 1882
  • Thank you received: 255
  • MODERATOR
1 year 3 weeks ago #278920

Hello,

I see from your screenshot that your view is an Item menu (or a module ?) did you check its specific configuration, see my screenshot :
In Menus => Main Menu OR Extensions => Modules, go to Products options tab



Here, the general is set like you to No, but I'm able to display the button on the whishlist thanks to this option in needed Item menu.
Hope this will help you.

Regards

Attachments:
Last Edit: 1 year 3 weeks ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 2
  • Hikashop Business
1 year 3 weeks ago #278972

I attach the screenshot from the settings of this particular menu item. It's set to No, like on my whole website. But still the buttons appear. So we have to look for another explanation.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 63584
  • Thank you received: 9158
  • MODERATOR
1 year 3 weeks ago #279053

Hi,

Then we're out of ideas. Please provide a backend access along with the necessary instructions and a link to this thread via our contact form so that we can directly look at the situation.
www.hikashop.com/support/contact-us.html

Please Log in or Create an account to join the conversation.

  • Posts: 63584
  • Thank you received: 9158
  • MODERATOR
1 year 3 weeks ago #279150

Hi,

The issue is that the setting "Display add to wishlist button in compare page" was activated in your HikaShop configuration even though the "enable wishlist" setting was turned off, and you couldn't see that setting because the enable wishlist setting was turned off.
So deactivating the "Display add to wishlist button in compare page" setting is the solution.
However, I'll make a patch so that even if that setting is activated, if the "enable wishlist" setting is turned off, the wishlist button shouldn't be displayed.

The following user(s) said Thank You: bolando

Please Log in or Create an account to join the conversation.

Time to create page: 0.103 seconds
Powered by Kunena Forum