Wishlist buttons seem not to do anything

  • Posts: 17
  • Thank you received: 6
1 year 1 month ago #282168

Hi there!

We are close to deliver a new site for our client. The site has no cart. It's purpose is to display products and maintain wishlists for visitors. They only sell products from within their physical store.

Normally people have to log in to put things on a wishlist.
For the purpose of this question / problem, I have made this available for all visitors.

As you can see, when clicking on a 'add to wishlist' button doesn't seem to do anything. We have tried from the products overview, as well as from a product detail page.

Any ideas on how to solve this?

Maurice


Cheers,
Maurice

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 6
1 year 1 month ago #282170

See one of the product category pages as an example: www.pyroshop.be/_2017/index.php/assortiment/klein-vuurwerk


Cheers,
Maurice

Please Log in or Create an account to join the conversation.

  • Posts: 64208
  • Thank you received: 9269
  • MODERATOR
1 year 1 month ago #282179

Hi,

When I click on the add to wishlist button there, the AJAX request for that action is sent to the server. However, the server answer with that response:
monosnap.com/file/u0Ud0k0IcVxqHWLe7bIJr8jw8CYNuX
As you can see, there is apparently an issue in one of the files of your Joomla template because apparently it doesn't handle properly the "tmpl=ajax" of the URL, which is a standard parameter of Joomla (albeit not used much usually).
As a quick fix, you can rename that /templates/lt_restaurant/error.php file to deactivate it and it might help.

Best regards,
Nicolas

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 6
1 year 1 month ago #282236

Thanks Nicolas!

I shared this thread with LTheme, I think it would be best if they try to fix the issue within the error.php file.
Will let you know how things turn out.


Cheers,
Maurice

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 6
1 year 1 month ago #282432

Hi Nicolas,

I managed to fix the issue.

First I tried your suggested quick fix and renamed the error.php file in the template. This did not change anything.
Second, when I switched to default Protostar template, it was still not possible to add anything to the wishlist. This clarified that this issue is not related to my template.

After some time I found out Admin Tools was blocking the 'tmpl=ajax' request. So it was easy to fix by changing the Admin Tools settings.

Thanks!


Cheers,
Maurice

Please Log in or Create an account to join the conversation.

  • Posts: 64208
  • Thank you received: 9269
  • MODERATOR
1 year 1 month ago #282435

Hi,

As yes. That's actually a known problem with Akeeba Backup.
We've already added fixes for that on most links but we missed a few. Next version will finally fix them all.

The following user(s) said Thank You: webcase

Please Log in or Create an account to join the conversation.

Time to create page: 0.084 seconds
Powered by Kunena Forum