translations dissapearing

  • Posts: 3
  • Thank you received: 0
  • Hikashop Essential
3 weeks 5 days ago #322034

-- HikaShop version -- : 4.3.0
-- Joomla version -- : 3.9.20.
-- PHP version -- : 7.3.5.
-- Browser(s) name and version -- : firefox 78.0.2

I upgraded to Hikashop essentials In order to be able to translate for example the shipping information. The Tabs are there and I can enter the translations and safe them. However they disappear. There is an error in the server log:

AH01070: Error parsing script headers, referer: ............index.php?option=com_hikashop&ctrl=plugins&task=edit_translation&shipping_id=13&type=shipping&language_id=2&tmpl=component
(url left out). Any Idea what to do?

Thanks Fred

Please Log in or Create an account to join the conversation.

  • Posts: 12482
  • Thank you received: 1716
  • MODERATOR
3 weeks 4 days ago #322038

Hello Fred,

Can you give us more information it like step by step instruction to reproduce it or about how they are disappearing through some screenshots for example ? so that we can reproduce it on our end ? Thank you.

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0
  • Hikashop Essential
3 weeks 4 days ago #322061

Hi Mohamed,

We first installed Hikashop starter, to see if it would fit our needs. Once happy with the possibilities of Hikashop we went on to the essential version.. We only use the translation option for the translation of the shipping and payment information to our 3 main languages. The information is set manually. see images attached. Entering the information seems to go normal including saving. But some time later the translated fields are empty again and the French and German Checkout pages revert to the English Base text. As to when the texts disappear I have the impression that it happens as soon as I for example change a translation in an other section for example the translation of a payment option. Last night we re-entered all translations from a different user account. Until now nothing seems to have disappeared yet.. But the parsing errors continue.
Thank You

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 70194
  • Thank you received: 10508
  • MODERATOR
3 weeks 3 days ago #322086

Hi,

The translations are stored in the file language/overrides/xx-XX.overrides.ini where xx-XX is the code of your language.
So I would recommend to save it.
That way, if the problem happens again:
- you can easily restore the translations by moving that file there again
- you can compare the backed up file against what you have there. If the translations are lost, it's probably because the file there became invalid for some reason.

Please Log in or Create an account to join the conversation.

  • Posts: 3
  • Thank you received: 0
  • Hikashop Essential
3 weeks 2 days ago #322118

Hi Nicolas,
Thanks for the suggestion, we will do more testing to see what happens, if new information arises we will inform you. Thanks Fred.

Please Log in or Create an account to join the conversation.

Time to create page: 0.062 seconds
Powered by Kunena Forum