Skip to main content

Finder CronJob error

More
2 years 3 weeks ago #363094 by smart web
-- HikaShop version -- : 5.1.1
-- Joomla version -- : 5.1.4
-- PHP version -- : 8.2.20

Hi,

When running the CronJob ‘/opt/php82/bin/php -d memory_limit=512M /home/httpd/vhosts/example.ch/test.example.ch/cli/joomla.php finder:index' or '/opt/php82/bin/php -d memory_limit=512M /home/httpd/vhosts/example.ch/test.example.ch/cli/joomla.php finder:index purge' I get the error:

In image.php line 61:

Call to undefined method Joomla\CMS\Application\ConsoleApplication::getTemp
late()
...


The error only occurs if the plugin ‘Smart Search - HikaShop Products’ is activated, otherwise the indexing via CronJob works perfectly.
Tested with Joomla 5.1.4 and HikaShop Business 5.1.0 + 5.1.1.

Thanks for checking
Stefan

Please Log in or Create an account to join the conversation.

More
2 years 3 weeks ago #363104 by nicolas
Replied by nicolas on topic Finder CronJob error
Hi,

Thank you for your feedback. We made a patch which should help.
Download again the install package of HikaShop 5.1.1 on our website and install it on yours in order to get the patch.

Please Log in or Create an account to join the conversation.

More
2 years 3 weeks ago #363115 by smart web
Replied by smart web on topic Finder CronJob error
Thank you for the quick patch, Nicolas. I am happy to confirm that the CronJob is working correctly again. I have just tested this on two systems with Joomla 5.1.4 and HikaShop Business 5.1.1.
The following user(s) said Thank You: nicolas

Please Log in or Create an account to join the conversation.

Time to create page: 0.138 seconds
Powered by Kunena Forum