I am having issues with Price display, On every edit-afer saving sets to FREE

  • Posts: 18
  • Thank you received: 0
  • Hikaauction Standard Hikamarket Multivendor Hikashop Business
3 weeks 3 days ago #306156

-- url of the page with the problem -- : eshop.bid/
-- HikaShop version -- : 4.0.3
-- HikaMarket version -- : 3.0.2
-- Joomla version -- : 3.9.5
-- PHP version -- : 7x
-- Error-message(debug-mod must be tuned on) -- : Inconsistent price and add to cart button

Issues with publishing Products

My initial test on publishing products, issue found Missing prices or Add to Cart button. Please see screenshot product Price display as FREE but actual price is set in the product editing form.



These issues are consistent when using this section ( New and Action=> Details)


HikaMarket seems to be using two different forms to publish or edit the product. Why? Shouldn't it be one?
See the difference between these forms as follow:

Edit form from Action=> Details
Note in the restriction and dimension the word Quantity



Form from Independent HikaMarket Menu
Note here the same section of restrictions and dimensions different spelling (Qty), as I previously changed it in Language file.

If it was the same form the Label Words would be the same in the same location, but it is not.

Any suggestions on this publishing issue will be very helpful It is really frustrating to see that it does not display the Price, knowing that the price was set.

Your help and support is appreciated.
Thank you.

Last edit: 3 weeks 2 days ago by webreplicator.

Please Log in or Create an account to join the conversation.

  • Posts: 23430
  • Thank you received: 3641
  • MODERATOR
3 weeks 2 days ago #306167

Hello,

1 - Product without price
Please note that your question is not related to HikaMarket but to HikaShop ; For your questions related to HikaShop itself, please use the dedicated section of the forum. The HikaMarket section is for HikaMarket questions only. Thanks for your understanding.
Not regarding your point, since your price have a date restriction, that it was "April 30" when you took the screenshot, of course you weren't into the date range (May 1 -> May 8 ) so there is no available price for the product.
The rest is just HikaShop settings and HikaShop translations.

2 - Display Consistency
These are just translations. I suppose that you have an override somewhere or that two language files are using the same translation key but the value is not the same ; depending how the components are loaded (and the order), one translation file can override another.
BUT !
In HikaMarket and HikaShop language file, both are using the same translations :

QUANTITY_PER_ORDER="Quantity per order"
Another possibility is that you're using two templates for these two menus and that you have view overrides (and one is not using translations but raw text instead)
So, only something external from HikaShop or HikaMarket could be the source of your issue.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikaauction Standard Hikamarket Multivendor Hikashop Business
3 weeks 2 days ago #306178

Thanks for your reply, I really appreciate it.
First of all, apologies for not posting this message in the right category. I am using Hikashopbusiness, HikaMarket and Auction and since I am publishing as a registered vendor... I thought it was HikaMarket issue.

Your explanation makes sense. However; after uploading new products, I noticed that any small editing to the published product causes it to ignore the pricing and it is set to FREE after saving.

I always have to remove the current price and then add it again, then it keeps it. It always happens in editing.

In regards to the language, I have no overrides. I have only made changes to the actual language file replacing the labels.
Example: Quantity to Qty.

I have not checked, but perhaps the form is calling these labels somewhere else in the language file. The language is not really a concern. The pricing issue is what really bothers me a bit. Other than that, it seems that I have figured out most of it. In fact today my website has gone to production status...I am excited.

It will be very helpful if you just, please try to edit a published product on your development environment and see if you experience this same issue (it only happens when editing).

Thank you

Last edit: 3 weeks 2 days ago by webreplicator.

Please Log in or Create an account to join the conversation.

  • Posts: 23430
  • Thank you received: 3641
  • MODERATOR
3 weeks 1 day ago #306179

Hello,

Please explain your issue.
We are not able to understand what you're talking about nor what is your "workflow".
So we cannot reproduce anything if we don't know what you're doing, what is an "upload", what you're modifying, what is the issue, etc.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikaauction Standard Hikamarket Multivendor Hikashop Business
3 weeks 1 day ago #306208

After having saved and published a product:

1. if I notice an error on my publication, a spelling mistake for example.
2. I decide to edit the product, correct the spelling.. then SAVE

3. After saved it set the existing price to FREE

Thanks

Please Log in or Create an account to join the conversation.

  • Posts: 23430
  • Thank you received: 3641
  • MODERATOR
3 weeks 12 hours ago #306210

Hello,

Your description does not allow us to reproduce the issue.
Please clarify.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikaauction Standard Hikamarket Multivendor Hikashop Business
2 weeks 6 days ago #306251

OK, What am I doing wrong. All I need to know is if the system is designed this way or is it an issue?

Editing at Front-end with HikaMarket

Please refer to this image at the beginning of thread:




The price is there and Start Date, End Date....Is the price and date set correctly?
If yes, why the display public price shows as free?

Again...it only sets it to FREE when editing and re-saving. In order to have my products displaying correctly, I must have to remove existing restrictions, then re-save it. Why do I have to reset these restriction when I am only correcting a spelling mistake?

Note that it is a total inconvenience resetting ( Product Price, start date, end date and available date, ending available date). In this current condition; On every edit I have to redo these restrictions all over again...every time.

Aren't my question valid? Am I the only one having this issue?

Your kind response is appreciated.
Thank you

Attachments:
Last edit: 2 weeks 6 days ago by webreplicator.

Please Log in or Create an account to join the conversation.

  • Posts: 23430
  • Thank you received: 3641
  • MODERATOR
2 weeks 4 days ago #306259

Hello,

It is still very difficult to understand your problem or to reproduce it with your description.

But, I do have the feeling that you have a timezone configuration issue.
Can you please try to edit the same product in the HikaShop backend and see if the time is also changing when you save a product ?

HikaMarket is using the same code than HikaShop ; so if you have some modification of the time when you save something via HikaMarket, it would mean that you have the same kind of issue with HikaShop.
In such condition, it would require to check your server timezone configuration (and Joomla too) ; thus it won't create a time shift between the reading of a date and the writing of one.
Since HikaMarket is using HikaShop core for that specific part, there is no patch I can provide directly.

CF : www.hikashop.com/forum/content-creation/...art-date.html#302766

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
The following user(s) said Thank You: webreplicator

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
  • Hikaauction Standard Hikamarket Multivendor Hikashop Business
2 weeks 3 days ago #306312

I reported the date and time issue, to my webHost. They have adjusted the server time and seems like it has been resolved.

If it continues I will let you know.

Thank you, I appreciate your help always.

Please Log in or Create an account to join the conversation.

Moderators: Obsidev
Time to create page: 0.090 seconds
Powered by Kunena Forum