Warning error Invalid Argument

  • Posts: 257
  • Thank you received: 4
  • Hikamarket Multivendor
3 months 4 days ago #307649

I am getting an error on the vendor page for adding new product. I do not get it if I log in as super user though.
Warning: Invalid argument supplied for foreach() in /home/public_html/administrator/components/com_hikamarket/classes/config.php on line 162

Attachments:
Last edit: 3 months 4 days ago by fan4chevy.

Please Log in or Create an account to join the conversation.

  • Posts: 23695
  • Thank you received: 3678
  • MODERATOR
3 months 3 days ago #307665

Hello,

The error means that your vendor do have some incorrect data for its vendor accesses.
Please check the vendor details in the backend ; but since you have another thread with vendor saving and empty required fields, it might be related.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 257
  • Thank you received: 4
  • Hikamarket Multivendor
3 months 3 days ago #307667

It turned out that the vendor did not have the required address filled in. Not sure how I was able to register the test vendor without having the required fields input. Seems like it would make me put them in before proceeding.

So I added info in the address and the error is gone.

Last edit: 3 months 3 days ago by fan4chevy.

Please Log in or Create an account to join the conversation.

Moderators: Obsidev
Time to create page: 0.063 seconds
Powered by Kunena Forum