Error at Checkout when I add coupon codes

  • Posts: 20
  • Thank you received: 0
11 years 4 weeks ago #21381

Hi,

During the checkout process, it's showing error message (enclosed) when I have a coupon code. When I unpublish or delete the coupon code (10%), the error message went away.

Please Log in or Create an account to join the conversation.

  • Posts: 20
  • Thank you received: 0
11 years 4 weeks ago #21382

I was not able to add the error display. Here is the error message:

Warning: constant()/[function.constant]: Couldn't find constant HIKASHOP_ORDER in /home/content/93/7848293/html/administrator/components/com_hikashop/helpers/helper.php on line 625.

Warning: constant()/[function.include-once]: failed to open stream: No such file or directory in /home/content/93/7848293/html/administrator/components/com_hikashop/helpers/helper.php on line 625.

Warning: constant()/[function.onclude]: Failed opening '.php' for inclusion (include_path='../usr/local/php5/lib/php') in /home/content/93/7848293/html/administrator/components/com_hikashop/helpers/helper.php on line 625.

Please Log in or Create an account to join the conversation.

  • Posts: 76114
  • Thank you received: 11912
  • MODERATOR
11 years 4 weeks ago #21387

Please Log in or Create an account to join the conversation.

  • Posts: 20
  • Thank you received: 0
11 years 4 weeks ago #21401

I read the explanation provided. The difference is that I'm on version 1.5.1 and I didn't set the coupon to auto load, is the instruction to change the php is still valid?

Also, do I have to upgrade to 1.5.2? My site just went live and I'm concern that the upgrade will screw up some of my customization changes in the Views, Language, etc. Please advise.

Also, does Hikashop have a way to know how many people view particular product page?

Please Log in or Create an account to join the conversation.

  • Posts: 76114
  • Thank you received: 11912
  • MODERATOR
11 years 4 weeks ago #21403

The modification should be the same for 1.5.1.

If you did your modifications via the interfaces we provide (the translations need to be changed in the override area), you will keep all your modifications when you update HikaShop.

In the latest version, there is a hit count which is updated each time someone sees a product page. You can then export the products data as a CSV and you will see the number of hits for each product in the column "product_hit" of the CSV that you can open with Excel or openoffice calc.

Please Log in or Create an account to join the conversation.

  • Posts: 20
  • Thank you received: 0
11 years 4 weeks ago #21414

Hi Nicolas,

When I made the recommended change to discount.php, I got the error message @ line 87:

Fatal error: Call to undefined function hikashop_table() in /home/content/93/7848293/html/administrator/components/com_hikashop/classes/discount.php on line 87

It seems like when I have the "quota per user" set to 1 that the error appears. If I don't, the coupon already applies during the checkout process which is not what I want. BTW, the type I setup is "coupons", not discount.

Please advise.

Please Log in or Create an account to join the conversation.

  • Posts: 76114
  • Thank you received: 11912
  • MODERATOR
11 years 4 weeks ago #21421

That's because before 1.5.2 the hikashop_table function was hikashop::table
If you change that part of the code with hikashop::table it will work.

Please Log in or Create an account to join the conversation.

  • Posts: 20
  • Thank you received: 0
11 years 3 weeks ago #21440

Hi Nicolas,

Thanks. The error message went away but the coupon I set up is applying the coupon "automatically" when I added a coupon code. The coupon code was set to not "auto apply." Please advise since it looks like it's doing what a discount type is doing.

Please Log in or Create an account to join the conversation.

  • Posts: 76114
  • Thank you received: 11912
  • MODERATOR
11 years 3 weeks ago #21446

Please post a screenshot of the configuration of the coupon ?

If the coupon is applied automatically, it must be that the configuration of the coupon has that auto load option on.
Otherwise, everyone else would have that issue when creating a coupon.

Please Log in or Create an account to join the conversation.

  • Posts: 20
  • Thank you received: 0
11 years 3 weeks ago #21457

Hi Nicolas,

Enclosed is the coupon configuration:




I tried adding another coupon code and it's still picking up the 10% automatically, but when I deleted the 10% one, the other coupon code seems to work now (w/o automatic apply). I guess the first coupon (shown) is a bad record or something. For now, there is no issue.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 20
  • Thank you received: 0
11 years 3 weeks ago #21458
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 76114
  • Thank you received: 11912
  • MODERATOR
11 years 3 weeks ago #21459

Hi,

So you're saying that now that you deleted this coupon, other coupons you created are working fine ? Well that's great :)
I don't see why that coupon would have been an issue though... That's really strange.

Please Log in or Create an account to join the conversation.

  • Posts: 20
  • Thank you received: 0
11 years 3 weeks ago #21463

Yes, so far, that's what happened. I'm not going to worry about since it's working for me. thank you for your quick replies.

Please Log in or Create an account to join the conversation.

Time to create page: 0.087 seconds
Powered by Kunena Forum