Can't Dismiss Empty Cart Notification

  • Posts: 17
  • Thank you received: 0
2 months 1 week ago #305831

Hi there. I've changed the empty cart to redirect to a product page, but when the "The cart is empty" alert message shows, the X close button does not work (and for some reason its also been moved to the left side above the text).

This only happens if I set a custom page for the empty cart?

Please Log in or Create an account to join the conversation.

  • Posts: 66041
  • Thank you received: 9666
  • MODERATOR
2 months 1 week ago #305837

Hi,

I believe the message is displayed with the Joomla messaging system by the template you're using.
Do you have the same issue if you use the default template of Joomla ?
Could you provide a link to the shop and instructions to reproduce the issue ?

The following user(s) said Thank You: workspace

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 0
2 months 1 week ago #305857

Thank you for your continued assistance.

Upon testing this issue does not happen with the default Joomla template. However I'm not sure exactly where the issue lyes as the alert message works fine if I don't set a redirect for the empty cart. The issue only happens with a custom URL to redirect to when the cart is empty.

Unfortunately I'm not sure how to provide a link to show the site as it's located on a private, password-protected server.

Please Log in or Create an account to join the conversation.

  • Posts: 66041
  • Thank you received: 9666
  • MODERATOR
2 months 1 week ago #305869

Hi,

When you're on the checkout and you get an error, as everything happens in AJAX (dynamically, without the whole page changing), the Joomla messaging system cannot display the messages. In that case, it's HikaShop which displays the messages itself.
However, we normally want to let the template display the messages so that they can be styled by the template.
Since you don't have the problem with another template, it's probably an issue in your template.
I would recommend to contact your template provider and give them precise instructions to reproduce the issue so that they can have a look at it.
We can have a look at it too. If you need to provide private information, please use our contact form and include a link to this thread along with the instructions to reproduce the issue:
www.hikashop.com/support/contact-us.html

The following user(s) said Thank You: workspace

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 0
2 months 1 week ago #305891

Upon testing, this error does indeed appear to be a template related issue. Thank you for your help.

Please Log in or Create an account to join the conversation.

Time to create page: 0.068 seconds
Powered by Kunena Forum