Default country is not selected in checkout

  • Posts: 134
  • Thank you received: 6
  • Hikashop Business
2 weeks 6 days ago #311598

-- HikaShop version -- : 4.2.1
-- Joomla version -- : 3.9.12
-- PHP version -- : 7.3
-- Browser(s) name and version -- : Chrome

I have a multilingual website with multiple countries in de checkout. I have the Netherlands selected as default in the country custom field. But when I go to the checkout always the first country (Argentina) from the list is selected.



could you tell me how to force the default country?

Thanks!

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 2256
  • Thank you received: 297
  • MODERATOR
2 weeks 5 days ago #311604

Hello,

For this, follow me step by step :
- From the Main HikaShop Configuration => Display dropdown => Customs Fields
- Use the filter dropdown selected on "Address"
- Click to edit on "address_country"
- See my screenshot :



Hope this will help you.
Regards

Last edit: 2 weeks 6 days ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 134
  • Thank you received: 6
  • Hikashop Business
2 weeks 2 days ago #311764

Thanks for the answer!

Prior to my question I already did test the setting, as I stated in my primary question! But the selection is not respected in the frontend.
That's the problem. Seems like a small bug...

Please Log in or Create an account to join the conversation.

  • Posts: 67199
  • Thank you received: 9963
  • MODERATOR
2 weeks 2 days ago #311770

Hi,

Make sure that you save the custom field once after selecting the default value, just to make sure that the value in the database is correct.
Also, check the "main tax zone" setting of the HikaShop configuration.
And finally, if you have the geolocation plugin activated, it can override the default country to use instead the geolocated country. But that would mean you would be using an IP address from Argentina in your tests which I suppose is not the case.

Please Log in or Create an account to join the conversation.

  • Posts: 134
  • Thank you received: 6
  • Hikashop Business
1 week 6 days ago #311920

Hi Nicolas,

Still no luck. I saved the custom field value again and the default tax category is set to Netherlands. Argentina is still selected.
For the time being I have set the "Add a 'Please select' value" to Yes so no country is selected.

Do you have some other ideas how to make this work?

Please Log in or Create an account to join the conversation.

  • Posts: 67199
  • Thank you received: 9963
  • MODERATOR
1 week 5 days ago #311932

Hi,

Nothing else comes to mind.
We would have to have a backend and FTP access and do some debugging to figure out what's going on here.

Please Log in or Create an account to join the conversation.

Time to create page: 0.079 seconds
Powered by Kunena Forum