Coupon not working correctly?

  • Posts: 196
  • Thank you received: 7
  • Hikaserial Subscription Hikashop Business
4 months 2 weeks ago #302130

Hello,
I have created a coupon with these settings: nimb.ws/hqGvXa

it auto-load in cart if the purchase is above 150 €, and it should apply a flat 3 0€ discount to all products overriding already discounted products

(I have some automatically discounted products for a certain user group, this discount settings: discount: nimb.ws/cK5OAI )

I was expecting it to override any already discounted products and be applied to all product in the cart, but it's behaving in a strange way
see test: nimb.ws/bizQ67

am I missing something in the configs?

UPDATE (more tests)
with these settings > ignore discounted products
- ]if in the cart there are only products which are already discounted, the coupon is not applied (0 discount)
- if in the cart there are mixed products, the applied discount behave strangely (see nimb.ws/bizQ67 )
- if in the cart there are only products which ARE NOT already discounted the coupon works correctly ( nimb.ws/BJhlFz )[/li]

the coupon is still being applied to already discounted products


Thank you

Last edit: 4 months 2 weeks ago by oloccina.

Please Log in or Create an account to join the conversation.

  • Posts: 2129
  • Thank you received: 287
  • MODERATOR
4 months 2 weeks ago #302146

Hello,

Thanks for all the elements you provide, it allow us to process some test on our localhost but, as your configuration is quite complex, can you provide via our contact us form any frontend/backend access in order to see it by ourself and process some test to better understand situation and quickly move forward on this subject.

Awaiting news from you.
Regards

Last edit: 4 months 2 weeks ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 196
  • Thank you received: 7
  • Hikaserial Subscription Hikashop Business
4 months 2 weeks ago #302158

done,
thanks for your support

Please Log in or Create an account to join the conversation.

  • Posts: 65661
  • Thank you received: 9582
  • MODERATOR
4 months 2 weeks ago #302161

Hi,
Looking at your settings, it's a lot more complex.
First, the taxes come into play. And based on how you set the "apply discounts" and "apply coupons" settings in the HikaShop configuration, it can change the results a lot.
I can see that you also have the "floating tax prices" setting activated. Combined with discounts, coupons, and the fact that the coupon should override the discounts, I'm not surprised that you're getting strange results. I don't think that anyone ever tested all of that combined together.

I think you want to set the same tax category as your products in the tax category setting of your discounts.
Also, you want to activate the automatic taxes settings of your coupons.
Then, I would recommend to try out switching the apply settings and test the several combinations.
That might already be enough.

Please Log in or Create an account to join the conversation.

  • Posts: 196
  • Thank you received: 7
  • Hikaserial Subscription Hikashop Business
4 months 2 weeks ago #302189

Thank you,
I applied your suggested settings and tested around, but it doesn's solve.
Anyway, let's just drop this, I'll find a different solution as it is not worth to really dig into this for me right now.

Please Log in or Create an account to join the conversation.

Time to create page: 0.057 seconds
Powered by Kunena Forum