Struggling to get coupons to work

  • Posts: 32
  • Thank you received: 1
10 months 2 weeks ago #330183

-- url of the page with the problem -- : thescienceoffiction.rocks
-- HikaShop version -- : 4.4.0
-- Joomla version -- : 3.9.24
-- PHP version -- : 7.4.14

I can't seem to get the coupon feature working.

I have created a coupon for a specific product (see settings image) and added that product to my cart. When I enter the coupon code I get an error saying the coupon isn't valid (see checkout image).

Where am I going wrong?

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 74542
  • Thank you received: 11498
  • MODERATOR
10 months 2 weeks ago #330193

Hi,

I'm not able to reproduce the problem on your website:
i.imgur.com/ELH8Dt7.png
The coupon code was accepted after adding the same product in the cart and registering.

Please Log in or Create an account to join the conversation.

  • Posts: 32
  • Thank you received: 1
10 months 2 weeks ago #330231

Seems to be working fine for me now, typical :D

Is there a way to add a line item for the coupon to the checkout table, showing the reduction in value, in a similar way to when using points?

Like,
Coupon -£1.00

Please Log in or Create an account to join the conversation.

  • Posts: 74542
  • Thank you received: 11498
  • MODERATOR
10 months 2 weeks ago #330233

Hi,

That should be the case by default. So I suppose that you must have turned off the "Show coupon price" setting under the "cart" view of the "checkout workflow" under the Checkout tab of the HikaShop configuration.
So please check on that setting.

The following user(s) said Thank You: jeffmcbiscuit

Please Log in or Create an account to join the conversation.

  • Posts: 32
  • Thank you received: 1
10 months 2 weeks ago #330306

Ahhhhhhhhhhh :)

Please Log in or Create an account to join the conversation.

Time to create page: 0.061 seconds
Powered by Kunena Forum