Cursor filter for price not working in module

  • Posts: 10
  • Thank you received: 0
4 years 9 months ago #266520

Hi,
I have this problem: The cursor filter for price is not working in the module, but it works if I define it to show in products list. So I guess the problem is in the module.
All other filters seem to work fine.

Please help.
Thanks

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 74554
  • Thank you received: 11499
  • MODERATOR
4 years 9 months ago #266544

Hi,

Can you provide a screenshot of the settings of your filter, one of the filter module settings and a link to that page so that we can analyze the situation ?

Please Log in or Create an account to join the conversation.

  • Posts: 10
  • Thank you received: 0
4 years 9 months ago #266580
Attachments:
Last edit: 4 years 9 months ago by celsoclaro.

Please Log in or Create an account to join the conversation.

  • Posts: 74554
  • Thank you received: 11499
  • MODERATOR
4 years 9 months ago #266591

Hi,

The problem is that you have a javascript error on that page:
monosnap.com/file/B3Aj12X84sLtJMD2tnuzPVww64AY8o
This comes from the mobile check of your menu system. It's probably coming from your template so I would recommend contacting them to see how to fix that javascript.
Once the javascript error is fixed, the javascript for the filter cursor will be able to initialize itself and it should work fine.

Please Log in or Create an account to join the conversation.

  • Posts: 143
  • Thank you received: 19
  • Hikashop Business
5 days 20 hours ago #338575

Hi,
I have this problem when the web site it's resized for mobile.
I use Gantry 5.5.7 as my template, and hikashop 4.4.5
I see that I have a error on my website, regarding a hikashop js file : /media/com_hikashop/js/nouislider.min.js?v=445

This message contains confidential information

Thank you!

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 74554
  • Thank you received: 11499
  • MODERATOR
5 days 15 hours ago #338576

Hi,

The issue is that you have each of your filter modules displayed twice on the page due to the filter icon for mobile devices.
Since they have the same id, the javascript to initialize the cursor filters only find the first instance.
This leads to these cursor filters not being initialized for mobile devices:
i.imgur.com/uQEDaYS.png
The solution is thus to duplicate the filter modules so that you have one set for the desktop and one set for the mobile devices.
That way, they won't interfer and you won't have the error and the cursor filters will be initialized properly for both types of devices.

The following user(s) said Thank You: oxido

Please Log in or Create an account to join the conversation.

Time to create page: 0.085 seconds
Powered by Kunena Forum