Certain backend pages not showing
12 years 8 months ago - 12 years 8 months ago #140008
by esotechie
Certain backend pages not showing was created by esotechie
-- url of the page with the problem -- :
www.esotechie.me.uk/administration
-- HikaShop version -- : 2.2.3 (and 2.2.2)
-- Joomla version -- : 3.2.1
-- PHP version -- : 5.3.27
-- Browser(s) name and version -- : Safari 7.0.1 (OSX 10.9.1) ; Safari (iOS 7.0.4) ; 26.0 (OSX 10.9.1) ; IE 8 (XP)
-- Error-message(debug-mod must be tuned on) -- : No error message is displayed (no page is loaded)
Links that show a blank page:
- Hikashop Configuration
- Products
- Categories
- Orders
- Add Product (shows page without CSS)
- Brands
- Import
I have bumped up the PHP memory to 336 and have taken out .htaccess in case these were the issue.
-- HikaShop version -- : 2.2.3 (and 2.2.2)
-- Joomla version -- : 3.2.1
-- PHP version -- : 5.3.27
-- Browser(s) name and version -- : Safari 7.0.1 (OSX 10.9.1) ; Safari (iOS 7.0.4) ; 26.0 (OSX 10.9.1) ; IE 8 (XP)
-- Error-message(debug-mod must be tuned on) -- : No error message is displayed (no page is loaded)
Links that show a blank page:
- Hikashop Configuration
- Products
- Categories
- Orders
- Add Product (shows page without CSS)
- Brands
- Import
I have bumped up the PHP memory to 336 and have taken out .htaccess in case these were the issue.
Last edit: 12 years 8 months ago by esotechie. Reason: Misspelling
Please Log in or Create an account to join the conversation.
12 years 8 months ago #140032
by nicolas
Replied by nicolas on topic Certain backend pages not showing
Hi,
Please turn on the debug mode and error reporting options of the joomla configuration and try again. That will display an error message instead of a blank page.
Please turn on the debug mode and error reporting options of the joomla configuration and try again. That will display an error message instead of a blank page.
Please Log in or Create an account to join the conversation.
12 years 8 months ago #140039
by esotechie
Replied by esotechie on topic Certain backend pages not showing
Hi Nicolas, thanks for the reply.
The debug is on and as I wrote next to the question "Error-message(debug-mod must be tuned on)" it is a blank page that is displayed.
The debug is on and as I wrote next to the question "Error-message(debug-mod must be tuned on)" it is a blank page that is displayed.
Please Log in or Create an account to join the conversation.
12 years 8 months ago #140059
by nicolas
Replied by nicolas on topic Certain backend pages not showing
Hi,
Then it means that the settings of your PHP forces it to not display them even if you try to enable them while running.
In that case, you'll have to look in the PHP error log file of your server for the error message (it should be a fatal error). If you don't know where that file is located, you'll have to ask your hosting company.
Then it means that the settings of your PHP forces it to not display them even if you try to enable them while running.
In that case, you'll have to look in the PHP error log file of your server for the error message (it should be a fatal error). If you don't know where that file is located, you'll have to ask your hosting company.
Please Log in or Create an account to join the conversation.
12 years 8 months ago - 12 years 8 months ago #140080
by esotechie
Replied by esotechie on topic Certain backend pages not showing
Thanks for the direction Nicolas.
The error is:
The memory limit is now set to the maximum of 512M but we still get the error which does not make sense to me.
I have also tried deleting the whole site and re-installing everything from scratch and have the same issue.
The error is:
esotechie.me.uk [Fri Jan 17 10:26:06 2014] [error] [client 86.21.50.55:33697] AH01215: PHP Fatal
error: Allowed memory size of 25165824 bytes exhausted (tried to allocate 107 bytes) in
/home/sites/esotechie.me.uk/public_html/libraries/joomla/language/language.php on line 813
The memory limit is now set to the maximum of 512M but we still get the error which does not make sense to me.
I have also tried deleting the whole site and re-installing everything from scratch and have the same issue.
Last edit: 12 years 8 months ago by esotechie.
Please Log in or Create an account to join the conversation.
12 years 8 months ago - 12 years 8 months ago #140083
by esotechie
Replied by esotechie on topic Certain backend pages not showing
Thanks for all the help Nicolas
It turned out to be a new file with PHP which the host was installing by default and I did not know about. It is .user.ini
Setting the limit in that seemed to do the trick.
Anyone using Heart Internet as service provider should watch out for this file if using their CGI to install Joomla.
It turned out to be a new file with PHP which the host was installing by default and I did not know about. It is .user.ini
Setting the limit in that seemed to do the trick.
Anyone using Heart Internet as service provider should watch out for this file if using their CGI to install Joomla.
Last edit: 12 years 8 months ago by esotechie.
Please Log in or Create an account to join the conversation.
Time to create page: 0.217 seconds