Paypal express missing product in cart payment

  • Posts: 53
  • Thank you received: 1
3 months 5 days ago #295465

-- HikaShop version -- : 3.4.1
-- Joomla version -- : 3.8.10
-- PHP version -- : 6.6.6

Hi at all,

last week I've configured the paypal express plugin upon request of PayPal team to have a promotion. Sometimes, but non every time the payment not correspond to client order. The payment is equal to te total of the order minus a product.

The issue seem due to the hikashop send an incomplete cart to PayPal, but i don't know the reason.

In the 2 orders where the issue are appared the products non reporte in the paypal cart are the last one available for each type. I don't know if this was a coincidence.

It could be a paypal express plugin setting problem ?

Many thanks an best regards

Luca

Please Log in or Create an account to join the conversation.

  • Posts: 11843
  • Thank you received: 1636
  • MODERATOR
3 months 4 days ago #295469

Hello,

Can you show us some screenshots of the issue you are having and of how you configured your PayPal express payment configuration page, so that we can have more information about it ? Thank you.

Best regards,
Mohamed Thelji.

Please Log in or Create an account to join the conversation.

  • Posts: 53
  • Thank you received: 1
3 months 4 days ago #295515

Hi,

in attached you can find the screen shot of plugin configuration (paypalExpress1.jpg, paypalExpress2.jpg), the order screenshot (Order.jpg, OrderDetail.jpg) and the screenshot of the PayPal payment detail.

Many thanks





Please Log in or Create an account to join the conversation.

  • Posts: 63606
  • Thank you received: 9161
  • MODERATOR
3 months 3 days ago #295524

Hi,

Are you able to reproduce the issue yourself ? (you should see if you get the correct data on PayPal payment page even without paying for the order)
Do you see something specific about the products that were missing from the PayPal payment ?
Also, could you try activating the debug setting of the PayPal express checkout payment method ?
Then, please look at the "payment log file" in the HikaShop configuration after an order with the issue is placed and provide the data relative to the order there.
Finally, another thing you can try is to turn off the "send order details" setting of the payment method and see if you still have the issue (the total paid should match).

Please Log in or Create an account to join the conversation.

Time to create page: 0.336 seconds
Powered by Kunena Forum