Authorize.net Phasing Out MD5 transHash

  • Posts: 18
  • Thank you received: 1
1 week 2 days ago #308409

Hi Nicolas,

Thank you so much for the prompt reply -- always very much appreciated. You can reproduce this by attempting to purchase anything from this site: www.tekneticsdirect.com

I wasn't able to see any CSS that would interfere, nor any javascript errors. Any insight would be greatly appreciated, as I have an important client waiting for a solution. Thanks so much!

Please Log in or Create an account to join the conversation.

  • Posts: 2188
  • Thank you received: 292
  • MODERATOR
1 week 1 day ago #308419

Hello,

You will need to provide a step by step process with all details like which kind of user account do you use, which product, which payment methods etc etc...

Because we make some tests on your website, and it seems that everything works well, see my screenshot :



Regards

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 1
1 week 1 day ago #308445

Hi Philip, thanks for getting back. Please make sure to choose Authorize.net during checkout, since PayPal appears to be working fine. The problem occurs with any product in the shop.

Please Log in or Create an account to join the conversation.

  • Posts: 2188
  • Thank you received: 292
  • MODERATOR
1 week 17 hours ago #308465

Hello,

You use an 2.6.4 HikaShop version with a more recent plugin, and so this kind of issue isn't really a surprise.
From this several solution for you :
- Update your HikaShop
- Don't use such recent payment plugin.

Sorry for this return.
Regards

Last edit: 1 week 1 day ago by Philip.

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 1
6 days 12 hours ago #308545

Hi Philip, yes, it’s an older version of HikaShop. Updating is on the to do list but it’s a big task and my client needs to be able to receive payments now. Do you have any ideas how we could make this plugin at least work for now?

Please Log in or Create an account to join the conversation.

  • Posts: 66303
  • Thank you received: 9727
  • MODERATOR
6 days 5 hours ago #308552

In the file authorize_end.php of the plugin, change the line:
hikaInput::get()->set('noform',1);
to:
JRequest::setVar('noform',1);
and in the file authorize.php of the plugin, change the line:
$value = hikaInput::get()->getString($key);
to:
$value = JRequest::getVar($key);
Note that you might have other issues using the plugin as this version of the plugin was made for HikaShop 4.x and recent versions of Joomla.

Please Log in or Create an account to join the conversation.

Time to create page: 0.070 seconds
Powered by Kunena Forum