Stripe V3 with Cpnnect SCA not working

  • Posts: 35
  • Thank you received: 0
  • Hikashop Business
2 months 2 days ago #316881

-- HikaShop version -- : 4.2.3

Hi Jerome

Posting this as a new thread as requseted, though I had to fib about 4.2.3;) . We will be updating it shortly., but only just done 4.2.2.
I managed to translate the French thread, and looks like a similar issue which is now resolved, so here's hoping you can do the same for us.

I recently purchase the Stripe V3 with Connect Plugin to update for SCA (not V2 as previously stated sorry), though I am still getting messages from Stripe that my payments are not SCA. Please could you advise as I need to get this fixed urgently.

www.backyardfarmer.co.uk
currently on Hika Business 4.2.2

If you could please check and tell me what I need to do to get it work, ie setting changes. The documentation didn't appear to match what the screen was showing.

Many thanks for your help.
Ruth

Please Log in or Create an account to join the conversation.

  • Posts: 24128
  • Thank you received: 3735
  • MODERATOR
2 months 2 days ago #316890

Hello,

Can you please provide a screenshot of your Stripe V3 settings ? (You can empty the credentials inputs to not share them)

These are the required settings :
Global credentials : No
Client ID : (empty, just need for the Stripe Connect integration)
Api Key: your API key
Publishable Key : Your key
Debug : Yes or No (depending if you want to have some debug data in the HikaShop payment log or not)
Payment mode : end page
Payment interface : Card (3D Secure)

If you do have settings with the 3D Secure payment interface and you do use that payment method for payments ; then you do are SCA compatible.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 24128
  • Thank you received: 3735
  • MODERATOR
2 months 1 day ago #316897

Hello,

Regarding your screenshot, you do not have the "Payment interface" parameters which means that you're not using the latest version of the plugin but an old one.
You have to download the latest version of the plugin via your HikaShop order.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

Time to create page: 0.040 seconds
Powered by Kunena Forum