Authorize.net issue: The transaction was declined

  • Posts: 17
  • Thank you received: 1
  • Hikashop Essential
1 month 2 weeks ago #341659

-- HikaShop version -- : 4.5.1
-- Joomla version -- : 3.9.22
-- PHP version -- : 7.4.29

Hi support,

I'm having problems with Authorize.net process. After the user clicks pay now on the Authorize.net Payment form. The user gets the message: "The transaction was declined".

The credit card used is valid, but even still this message appears. I tested with the test payment and debug turned on, but I got no message on the payment file log. I attached the error message, also the screenshot of the setting on the authorize.net plugin. Please, take a look and let us know why this is happening only with authorize.net.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 75924
  • Thank you received: 11857
  • MODERATOR
1 month 2 weeks ago #341661

Hi,

This error is output by Authorize.net's server. It's a generic error message so it doesn't say exactly what is the problem.
However, it's likely it comes from some verification on Authorize.net, like the Address Verification Service (and in this instance, there are some settings in your Authorize.net merchant account to configure it).
The best is to check with Authorize.net merchant support since they have access to the details log of what happened for each transaction on their end, which HikaShop and us don't have access to.

Please Log in or Create an account to join the conversation.

Time to create page: 0.054 seconds
Powered by Kunena Forum