Hikaskop filter search 4.2.2

  • Posts: 113
  • Thank you received: 3
  • Hikashop Business
5 months 2 weeks ago #310333

-- url of the page with the problem -- : lebasport.nl and hikashop.com
-- HikaShop version -- : 4.2.1
-- Joomla version -- : 3.9.11
-- PHP version -- : 7+
-- Browser(s) name and version -- : firefox latest, chtome, Safari

Hi,

When a "product page" is displayed the Hikashop filter search doesn't work. This is also on the hikashop.com page see the image attachement.

• i have disabled the module display in the product page, so the customer has to go back to the product listing or disable the search text.
• today installed the latest patch of Hikashop buss 4.2.1
regards,

Marius

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 68134
  • Thank you received: 10159
  • MODERATOR
5 months 2 weeks ago #310351

Hi,

I'm not able to reproduce the problem on our demo website.
When I go to a product page, enter the text "porsche" in the search box on the left and click on the "filter" button, I get this page:
monosnap.com/file/ni7fZUESAFh46zc02wHCVM62ig4RU1
Which is the products listing result page of the search I made.
It seems to work just fine from what I could test. So I must be missing some information to reproduce the problem.
Could you provide more information on what you're doing ? Can you confirm that you have the issue with "Chrome" (I'm using Chrome on my end) ?

Please Log in or Create an account to join the conversation.

  • Posts: 113
  • Thank you received: 3
  • Hikashop Business
5 months 2 weeks ago #310353

hi Nicolas,

Yes when in a normal presentation of a product page the search is good working, but when it is a product page that was "searched" then it stops.

In the demo i searched "stiletto" and looked in the found productpage, then search on "grey" no progress any more.
This in Chrome, Google Chrome is up-to-date
Versie 76.0.3809.132 (Officiële build) (64-bits)

So my client want that a customer always can keep on searching as much he will. Ohterwise the customer has to make more clicks.
Will you look again,
nice day,
Marius

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 68134
  • Thank you received: 10159
  • MODERATOR
5 months 2 weeks ago #310361

Hi,

Thanks, I was able to reproduce the problem on my end.
Change the line:

if(!$this->params->get('force_redirect',0) || $Itemid == $this->params->get('itemid')) {
to:
if(!$this->params->get('force_redirect',0) || ($Itemid == $this->params->get('itemid') && $task == 'listing')) {
in the file components/com_hikashop/views/product/view.html.php and that should fix the problem.
I've applied the change to the master website of the demo website. It should be working fine on the live demo website in a few hours.

The following user(s) said Thank You: mariussport

Please Log in or Create an account to join the conversation.

  • Posts: 113
  • Thank you received: 3
  • Hikashop Business
5 months 2 weeks ago #310393

Thank you,
Searching works now perfect! (and fast)

close this topic.

beste regards,

Marius

The following user(s) said Thank You: nicolas

Please Log in or Create an account to join the conversation.

  • Posts: 113
  • Thank you received: 3
  • Hikashop Business
4 months 1 day ago #312187

Hi, i was to fast, it seems to work niw after 15 minutes, sorry!! don,t react OK

(We had so a perfect Hika search installation, but after update to 4.2.2 (yesterday and even the last patch of today) it will only work in the product listing (menu)
I have two test sites on localhost the Hika search filter works not in the catagory listing, product page and not after a search before

in one site the content is empty (blanc) (patch today)
In one site i get a 404 error, cache is cleared several times.
can you take a look?
regards,)

Marius

Last edit: 4 months 1 day ago by mariussport. Reason: it works now thanks.

Please Log in or Create an account to join the conversation.

  • Posts: 68134
  • Thank you received: 10159
  • MODERATOR
4 months 1 day ago #312188

Hi,

Sure we can look into it. We would need that you provide the links and instructions to reproduce the problems so that we can look into them.
However, reading your message it seems all good. Do you still need help or not ? I'm confused.

Last edit: 4 months 1 day ago by nicolas.

Please Log in or Create an account to join the conversation.

  • Posts: 113
  • Thank you received: 3
  • Hikashop Business
4 months 1 day ago #312230

hi,

no thanks, i am local making a complete new test version, so that Joomla and Hikashop is clean.
OK

Marius

Please Log in or Create an account to join the conversation.

  • Posts: 113
  • Thank you received: 3
  • Hikashop Business
4 months 19 hours ago #312246

hi Nicolas,

search filter works only in listing also in your demo site. (it is a 4.2.2. see the switch in listing)

Will you have a look at the Hikshop demo site, there i find the same problem. That only the filter works in the product listing (menu) Not in the category display (menu) or other pages, searche result products page etc. When you search you get a 404 error. Thats what i asked you wil you have a look.
I thought first that it was a problem in my tests sites, and i did disable/remove all things like OSmap and other plugins, maked a new test Joomla site with only Hikashop 4.2. but the filter keeps restricted.
The search filter is for very important and we like it will work over all the site. Sorry it was realy so perfect before and still active in the live site, i will not upgrade the live shop.

best regards,
Marius

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 68134
  • Thank you received: 10159
  • MODERATOR
3 months 4 weeks ago #312268

Hi,

Change the line:
$url = hikashop_completeLink($type.'&Itemid='.$id);
to:
$url = hikashop_completeLink($type.'&task=listing&Itemid='.$id);
in the view file product / filter.php via the menu Display>Views and that will fix the problem.
We'll add that on our end too.

Please Log in or Create an account to join the conversation.

  • Posts: 113
  • Thank you received: 3
  • Hikashop Business
3 months 4 weeks ago #312272

thanks Nicolas, done so and works perfect now.
regards, Marius

Please Log in or Create an account to join the conversation.

Time to create page: 0.075 seconds
Powered by Kunena Forum