Customers does not received confirmation email for their order

  • Posts: 29
  • Thank you received: 0
  • Hikashop Business
2 weeks 5 days ago #315216

-- HikaShop version -- : 4.2.2
-- Joomla version -- : 3.9.15
-- PHP version -- : 7.3

Hi!
I did not find any setting related to an email that would be sent to the customer for his order once completed. I supposed it is automatic but unfortunately, it doesn't work. Is there a setting I missed somewhere about that?

Please Log in or Create an account to join the conversation.

  • Posts: 68132
  • Thank you received: 10158
  • MODERATOR
2 weeks 4 days ago #315226

Hi,

HikaShop sends two emails to the customer after an order:
- the "order creation notification" is sent just after the order is created, all the time but you can deactivate it via the System>Emails menu.
- the "order status notification" is sent either when you manually change the status of an order and activate the user notification checkbox, or when a payment plugin automatically changes the status of the order to "confirmed". Similarily, you can deactivate it via the System>Emails menu.
If all this is correct but the emails are not received by the user, you should check the Customers>Email history menu. There, you'll see all the emails sent by HikaShop. If you see the email there but the user didn't receive it, it means that there is an issue with either:
- the email getting flagged as spam by the receiver email server (you should check your emails egainst www.mail-tester.com/ )
- the email couldn't be sent by your email server. In that case it could come from the Email settings of the Joomla configuration, or the email settings of the HikaShop configuration or some issue on the email server itself (like the email sending queue is full). So in that case, you'll likely want to check the log of the email server to see what was the error for the email sending process. Most of the time, you'll have to ask your hosting support about it as you usually can't check the email server logs yourself unless you have a dedicated server with your own email server.

Please Log in or Create an account to join the conversation.

  • Posts: 29
  • Thank you received: 0
  • Hikashop Business
2 weeks 1 hour ago #315362

Thank you for all this information.

The email mentionned above are all activated. Emails work most of the time so I guess is not a Joomla configuration issue. I will check further for the Spam.

Please Log in or Create an account to join the conversation.

  • Posts: 68132
  • Thank you received: 10158
  • MODERATOR
1 week 6 days ago #315369

Hi,

Also check in Customers>Emails history. If someone reports not receiving the email notification, check if you have it there. If it's there and he doesn't get it, while other emails are sent properly, it's highly likely to be a spam issue.
If the email is not in the email history, then it's something else.

Please Log in or Create an account to join the conversation.

Time to create page: 0.056 seconds
Powered by Kunena Forum