BitCoin Plugin?

  • Posts: 13201
  • Thank you received: 2316
  • MODERATOR
4 years 5 months ago #154736

Hi,

Could you give us an url to your website and a test account in order to make some tests on your website ?

Please Log in or Create an account to join the conversation.

  • Posts: 121
  • Thank you received: 7
4 years 3 weeks ago #173005

Hey guys,

I've finally gotten around to reactivating the Bitcoin plugin and it's working this time! Payments are confirmed and orders are automatically fulfilled.

There do seem to be a few glitches still though, having to do with payment speed. I've read the Bitpay API guide and I'm not quite sure how to figure out how Hikashop is implementing some stuff.

  • The way the plugin is set up by default, with only 'complete' Bitpay status confirming a Hikashop order, this means that the speed option is totally irrelevant because orders will only be confirmed once Bitpay gets 6 confirmations (this is the same as Slow speed according to API guide)
  • I changed the speed to Medium, and the 'confirmed' Bitpay status to confirmed in Hikashop. This should have resulted in a transaction that is confirmed once Bitpay gets 1 confirmation, but it took exactly as long as the above order - and required 6 confirmations still.
  • I changed the speed to High, and still the same - 6 confirmations required and about 30-40 minutes.

I looked and I can't find any current documentation for the Bitcoin plugin, which is why I am posting this here. If you'd prefer I open a new thread let me know.

Last Edit: 4 years 3 weeks ago by jeremynsl.
The following user(s) said Thank You: Jerome, samuel

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 1
6 months 3 days ago #291482

Dear All,
I know this is a very old post, but I wonder whether any of you is still using this plugin?
I used if for over a year, but some months back it stopped working.
I am not sure what is wrong or where to look at, but hope I could do it with some guidance.
My problem is that after hitting the 'Finish' button at the checkout the shop gets stuck in this link:
example.com/index.php/store-categories-l...out/task-step/step-1
If I go back to the page or reload the website the cart is still full, so the transaction hasn't been completed.
I don't have the same problem when I use any other payment method, so I'd assume the overall flow is correct.
Any clues?
Thanks!

Please Log in or Create an account to join the conversation.

  • Posts: 63607
  • Thank you received: 9161
  • MODERATOR
6 months 3 days ago #291485

Hi,

What you could do is try switching to the new checkout of HikaShop by deactivating the "checkout legacy" setting in the HikaShop configuration.

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 1
6 months 3 days ago #291503

Thanks for your prompt reply.
Now the page gets stuck in the link:
example.com/index.php/store-categories-l.../confirm/cart_id-240

Please Log in or Create an account to join the conversation.

  • Posts: 11844
  • Thank you received: 1636
  • MODERATOR
6 months 2 days ago #291522

Hello,

Can you give us more information about your issue through some screenshots for example so that we can have a better understanding of your issue ?

Thank you.

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 1
6 months 1 day ago #291615

Hi,
I don't really have more info to share.
The process goes without any issue until the user press the 'Finish' button in the checkout screen.
From there the browser goes to a blank page where the URL indicated in the page is:

example.com/index.php/store-categories-l.../confirm/cart_id-240 (if we use the new checkout)

or

example.com/index.php/store-categories-l...out/task-step/step-1 (if we use the legacy checkout)

Any clues?

Thanks

Please Log in or Create an account to join the conversation.

  • Posts: 22884
  • Thank you received: 3551
  • MODERATOR
6 months 1 day ago #291616

Hello,

If you have a blank page, it would suggests a PHP Fatal Error.
You should take a look at your PHP error log for more details ; or activate temporally the "error report level" to "maximum" in your Joomla global configuration.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.
The following user(s) said Thank You: kikobar

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 1
6 months 1 day ago #291623

Thanks Jerome!
I look at the php error log and found the fatal errors as you suggested.
The fatal error was an undeclared CURL function, which led me to find the problem...
It seems someone had re-installed the server and forgot to re-install CURL, otherwise it would have never worked before.
Now it is working again.
Regards,

The following user(s) said Thank You: Jerome

Please Log in or Create an account to join the conversation.

Time to create page: 0.112 seconds
Powered by Kunena Forum