Mauvais lien lors du clique sur la langue choisie

  • Posts: 34
  • Thank you received: 2
  • Hikashop Business
1 month 2 weeks ago #337495

-- HikaShop version -- : 4.4.4
-- Joomla version -- : 3.10.3
-- PHP version -- : 7.3.31
-- Browser(s) name and version -- : 96.0.4664.45

Bonjour,

Lorsque je suis sur la page https://www.diableelectrique.com/fr/monte-escaliers/monte-escaliers-charges-lourdes/product/c400https://www.diableelectrique.com/fr/monte-escaliers/monte-escaliers-charges-lourdes/product/c400 et que je clique sur le lien en haut à droite "fr", je suis censé revenir sur la même page. Il s'agit du switcher de langue de Joomla et l'autre langue est invisible car je n'ai pas encore reçu les traduction du client.
Ce lien "fr" fonctionne pourtant avec un autre article https://www.diableelectrique.com/fr/monte-escaliers/monte-escaliers-charges-legeres/product/cc160https://www.diableelectrique.com/fr/monte-escaliers/monte-escaliers-charges-legeres/product/cc160 .

J'ai l'impression que tout les articles de la catégorie "Monte-escaliers charges lourdes" ont le problème et pas les articles de la catégories "Monte-escaliers charges légères".

Pouvez-vous m'aider pour résoudre le problème des articles de la catégorie "Monte-escaliers charges lourdes" ?


Merci d'avance.

Please Log in or Create an account to join the conversation.

  • Posts: 74542
  • Thank you received: 11498
  • MODERATOR
1 month 2 weeks ago #337500

Bonjour,

Je dirais qu'il manque le nom et/ou l'alias dans les produits de cette catégorie alors que ce n'est pas le cas pour les produits de l'autre catégorie.
Pourriez-vous vérifier ?

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 2
  • Hikashop Business
1 month 2 weeks ago #337518

Bonjour,

Tous les produits ont bien un nom et un alias ainsi que les deux catégories.
Avez-vous une autre piste ?

Merci d'avance.

Please Log in or Create an account to join the conversation.

  • Posts: 74542
  • Thank you received: 11498
  • MODERATOR
1 month 2 weeks ago #337528

Bonjour,

Difficile à dire. pourriez vous fournir une capture d'écran des options d'un produit avec le souci et aussi une capture de la popup de traduction pour ce produit ?

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 2
  • Hikashop Business
1 month 2 weeks ago #337542

Rebonjour,

Voici deux saisies d'écran.
Le C120 fonctionne parfaitement et le a350 pose problème.
Je n'ai pas mis de saisie d'écran du popup pour les traduction, car il n'y a rien dedans ni pour le c120, ni pour l'a350.

Merci.

Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 74542
  • Thank you received: 11498
  • MODERATOR
1 month 2 weeks ago #337550

Bonjour,

Les captures sont trop petites et je n'arrive pas à lire le texte dessus. Peut être pourriez-vous les fournir via wetransfer.com/
Aussi, il n'y a pas de capture de la popup de traduction FR (lorsqu'on appui sur le drapeau Français).

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 2
  • Hikashop Business
1 month 2 weeks ago #337601

Bonjour,

Désolé pour la réponse tardive et encore merci de vous occupez de mon cas.
Voici le lien wetransfert : wetransfer.com/downloads/0424d89796df20f...0211202074410/89fd8c

Comme mentionné précédemment, le popup de traduction est vide pour TOUT les produits, ceux qui fonctionne et ceux qui ne fonctionne pas.

Bien à vous.

Please Log in or Create an account to join the conversation.

  • Posts: 74542
  • Thank you received: 11498
  • MODERATOR
1 month 2 weeks ago #337621

Bonjour,

Merci pour les captures.
Bizarre du coup. Je ne vois pas ce qui pourrait faire cela.
Serait-il possible d'avoir un accès FTP et backend via notre formulaire de contact pour pouvoir étudier le problème plus en détails ?
www.hikashop.com/support/contact-us.html

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 2
  • Hikashop Business
1 month 2 weeks ago #337626

Rebonjour,


Je viens d'envoyer le formulaire avec comme objet : Mauvais lien lors du clique sur la langue choisie


Bien à vous.

Please Log in or Create an account to join the conversation.

  • Posts: 74542
  • Thank you received: 11498
  • MODERATOR
1 month 2 weeks ago #337660

Bonjour,

Merci pour l'accès FTP.
J'ai pu regardé plus en profondeur le souci.
La différence vient en fait de l'association par langue de vos éléments de menu.
C'est fait pour l'un et pas pour l'autre, et il y a un souci dans le code du système de calcul des liens qui ne prend pas correctement en compte l'alias du produit dans l'URL lorsque l'association est manquante dans l'élément de menu.
J'ai fait un patch pour quand même prendre en compte l'alias du produit dans ce cas et cela semble maintenant fonctionner comme il faut sur votre site.
Nous allons rajouter cette modification de notre coté également.

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 2
  • Hikashop Business
1 month 2 weeks ago #337663

Un tout grand merci.

Félicitation pour le support.

The following user(s) said Thank You: nicolas

Please Log in or Create an account to join the conversation.

Time to create page: 0.086 seconds
Powered by Kunena Forum