Confirmation email not sent to customer on multi-vendor orders

  • Posts: 287
  • Thank you received: 32
  • Hikamarket Multivendor Hikashop Business
1 year 2 months ago #325451

-- HikaShop version -- : 4.4.0 [2011031346]
-- HikaMarket version -- : 3.1.1 [2008162014]
-- Joomla version -- : 3.9.22
-- PHP version -- : 7.2.34

Hi

When a customer places an order with products from more than one vendor they do not receive a 'Confirmation' email. Emails to vendors are sent correcty as are the 'Created' emails. If the order is for products from a single order the 'Confirmation' order is received OK.

Not sure if is related but the word 'Array' is displayed in the email log and a few other places.

Email log for a single vendor order:



Email log for 2 vendor order:


Email settings:


The word 'Array' also appears at the bottom of the payment and shipping methods pages:


I have copied the site to a temporary server if you are able to take a look.

Best regards
Trevor

Last edit: 1 year 2 months ago by trevsmiff.

Please Log in or Create an account to join the conversation.

  • Posts: 25146
  • Thank you received: 3892
  • MODERATOR
1 year 2 months ago #325515

Hello,

Would it be possible that we patched your website some time ago and forgot to remove a debug trace ?
Or maybe you have a custom plugin ?

In our demo website (or my test websites), I cannot see any "Array" content in the backend payment or plugin edition.

Regards,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 287
  • Thank you received: 32
  • Hikamarket Multivendor Hikashop Business
1 year 2 months ago #325525

Hi Jerome

I have run some tests on my test site and have found that the 'Array' text on the shipping and payments method pages is caused by the maximenuhikashop plugin.

With the plugin disabled the 'Confirmed' email is still not sent to the customer using the Stripe method and 'Array' still appears in the email log.
I repeated the test using the Bank Transfer method and manually marking the order 'Confirmed' and the email was sent correctly.

Regards
Trevor

Please Log in or Create an account to join the conversation.

  • Posts: 287
  • Thank you received: 32
  • Hikamarket Multivendor Hikashop Business
1 year 2 months ago #325539

I have repeated the test but paid with PayPal this time and get the same results - 'Created' emails are all sent OK and 'Confirmed' emails are also sent but not to the customer.This time the email log recorded the 'Created' emails but there were no enties for the 'Confirmed' emails!

regards
Trevor

Please Log in or Create an account to join the conversation.

  • Posts: 287
  • Thank you received: 32
  • Hikamarket Multivendor Hikashop Business
1 year 2 months ago #325582

I might have found the cause of the problem in an email override. I need to re-load my test site and test again.
Trevor

The following user(s) said Thank You: Jerome

Please Log in or Create an account to join the conversation.

  • Posts: 287
  • Thank you received: 32
  • Hikamarket Multivendor Hikashop Business
1 year 2 months ago #325591

Problem solved. It was cauused by an override to the order_status_notification emails which was made many versions ago.

Thanks for your help
Trevor

The following user(s) said Thank You: nicolas

Please Log in or Create an account to join the conversation.

Moderators: Obsidev
Time to create page: 0.092 seconds
Powered by Kunena Forum