The vendor est expiré

  • Posts: 82
  • Thank you received: 15
  • Hikashop Business
2 months 1 week ago #359820

-- url of the page with the problem -- : sofleurs.fr
-- HikaShop version -- : 5.0.3
-- HikaMarket version -- : 4.1.1
-- Joomla version -- : 3.10.12
-- PHP version -- : 7.4.33
-- Error-message(debug-mod must be tuned on) -- : The vendor est expiré

Hello,
Je gère un site avec Hikamarket, sur lequel les 2 derniers vendeurs inscrits ne peuvent être affichés, il m'est d'abord demandé de me connecter, puis lorsque je refais la recherche en étant connecté le lien me ramène sur la page d'accueil avec le message d'erreur "The vendor est expiré"
Je ne sais pas si cela peut avoir un lien, mais étonnamment c'est depuis le "vendor_id" 300 de la table "hikamarket_vendor" que j'ai ce problème.
Y a-t-il une limitation par rapport à cette table ?
Merci d'avance

Please Log in or Create an account to join the conversation.

  • Posts: 26034
  • Thank you received: 4006
  • MODERATOR
2 months 1 week ago #359822

Bonjour,

Le message va s'afficher si le vendeur est dépublié.
Il n'y a rien dans le code qui pourrait faire un changement de comporter sur le nombre de vendeurs dans votre base de données.

Cordialement,


Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Also helping the HikaShop support team when having some time or couldn't sleep.
By the way, do not send me private message, use the "contact us" form instead.

Please Log in or Create an account to join the conversation.

  • Posts: 82
  • Thank you received: 15
  • Hikashop Business
2 months 4 days ago #359864

Hello Jerome,
Je te remercie de ta réponse, mais ce n'est évidement pas qu'une question de publication, c'est la 1ère chose que j'ai regardé...
Tout de même étonnant que le problème se pose à partir de l'ID 300
T'as pas une autre idée ?
Je sui coincé, si je ne trouve pas de solution je vais devoir tout refaire avec un autre système car ce n'est pas concevable pour mon client que la base des revendeurs ne puisse plus évoluer

Please Log in or Create an account to join the conversation.

  • Posts: 81715
  • Thank you received: 13104
  • MODERATOR
2 months 4 days ago #359867

Bonjour,

Serait-il possible d'avoir une capture d'écran des paramètres d'un vendeur avec le souci ?

Please Log in or Create an account to join the conversation.

  • Posts: 82
  • Thank you received: 15
  • Hikashop Business
2 months 4 days ago #359883

Hello Nicolas,
Ça y est j'ai trouvé... ce n'est effectivement pas lié à l'ID, il y a de nombreuses autres fiches qui ne s'affichent pas en raison du même bogue que j'avais déjà signalé il y a 16 mois de cela : il n'est pas possible de mettre un caractères spécial dans le champ "Nom" à cause de l'URL qui ne se construit pas correctement : www.hikashop.com/forum/19-hikamarket/905...echerche-joomla.html
J'avais oublié ce gag car depuis l'époque je laisse le client gérer son site seul, du coup au final j'ai de nouveau perdu 1 journée à cause de ce problème, ce serait cool s'il pouvait être corrigé, nous devons pouvoir écrire le nom du revendeur avec un accent s'il en contient un.
Les revendeurs sont des entreprises de pompes funèbres, du coup le è de funèbre revient régulièrement ;)

Please Log in or Create an account to join the conversation.

  • Posts: 82
  • Thank you received: 15
  • Hikashop Business
2 months 4 days ago #359884

Voici le champ qui pose problème...


Je précise que le site est encore sous Joomla 3, je vais le migrer d'ici cet été, du coup je sais pas si ce problème se produit également avec Joomla 4 ou 5

Attachments:

Please Log in or Create an account to join the conversation.

Moderators: Obsidev
Time to create page: 0.076 seconds
Powered by Kunena Forum