Skip to main content

Error upgrading tables

More
13 years 1 month ago #120829 by zebrafilm
-- url of the page with the problem -- : mywebsite.com/mypage
-- HikaShop version -- : 2.2.1 bizz
-- Joomla version -- : 3.15
-- PHP version -- : 5.4
-- Browser(s) name and version -- :
-- Error-message(debug-mod must be tuned on) -- : Error_message

After upgrading a standard Hika to the business version I got this error:

Duplicate column name 'field_display' SQL=ALTER TABLE `qbuwg_hikashop_field` ADD `field_display` text NOT NULL DEFAULT '';

Any clue? How to fix this best? Remove the table or field?

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago - 13 years 1 month ago #120850 by Mohamed Thelji
Hi,

Duplicate column name 'field_display' SQL=ALTER TABLE `qbuwg_hikashop_field` ADD `field_display` text NOT NULL DEFAULT '';

This error message is only saying that you already had the 'field_display' column into your "hikashop_field" table, so I don't think that you'll have some problem regarding this error.

Hope this will help you a litlle.
Last edit: 13 years 1 month ago by Mohamed Thelji.

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago - 13 years 1 month ago #120910 by zebrafilm
Replied by zebrafilm on topic Error upgrading tables
THanks but this not an answer. sorry :-)

I am comfortable in DBses but this normally does not happen on any update. I am also having other issues with that site and this might be related. It seems related to having the two other versions here before we updated to the bizz version.
Unfortunately we already put a lot of work in there otherwise I would strip everything and start fresh.

I have done two re-installs to see if that helped but none did.

I want to clear errors like that before I start submitting other issue......
Last edit: 13 years 1 month ago by zebrafilm.

Please Log in or Create an account to join the conversation.

More
13 years 1 month ago #120911 by zebrafilm
Replied by zebrafilm on topic Error upgrading tables
OK remade the field manually and it seem to have solved that issue.
The following user(s) said Thank You: Jerome

Please Log in or Create an account to join the conversation.

Time to create page: 0.215 seconds
Powered by Kunena Forum