Skip to main content

After Hikashop update - invoice error

More
12 years 11 months ago #128249 by scharfet
-- url of the page with the problem -- : www.monpetitpot.es
-- HikaShop version -- : 2.2.2
-- Joomla version -- : 2.5.14

Hello!

After updating Hikashop or caused by installing "Plugin PDF" (deactivated) (when activated the error does not occur and I need the plugin deactivated for now).

When I click on Invoice to see the invoice following error is displayed:
Code:
Parse error: syntax error, unexpected $end in /homez.428/monpetit/www/administrator/templates/bluestork/html/com_hikashop/order/invoice.php on line 516

Line 516 is the last line in the php file
Code:
<div style="page-break-after:always"></div>

I use a view override. Without the view override the error does not occur. But many changes were made in this override so it would be greate if the error within this file could discovered.
Could this be a big error or a easy one to solve?

Thank you!

Please Log in or Create an account to join the conversation.

More
12 years 11 months ago #128254 by Jerome
Hi,

You made a view override and I think that you put a open bracket which does not have his "close" brother.
That's why PHP tells you that there is a missing "$end" at the last line of the file, because it can't find the close bracket.

The problem is in your override "invoice.php" file, so it is related to something you changed.

Regards,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
The following user(s) said Thank You: scharfet

Please Log in or Create an account to join the conversation.

Time to create page: 0.183 seconds
Powered by Kunena Forum