Skip to main content

Error affichage page admin/products après MAJ

More
12 years 1 month ago #167288 by MAKEDIFFERENT
-- HikaShop version -- : Latest
-- Joomla version -- : Latest
-- Error-message(debug-mod must be tuned on) -- : dTree is not defined

Bonjour,

J'ai fait la MAJ de Hikashop sur le site précisé plus haut, mais j'obtiens l'erreur suivante sur la page des produits sur hikashop. Est-il possible de me préciser la marche à suivre pour régulariser ce problème.

La page Catégories fonctionne bien.

Merci

--
MAKE DIFFERENT, l'Agence web différente, Cergy.

Please Log in or Create an account to join the conversation.

More
12 years 1 month ago #167298 by nicolas
Bonjour,

Cela indique une erreur fatale d'execution.
Activez le 'error reporting' et "debug mode" de la configuration joomla et réaffichez la page. Regardez en bas et vous aurez le vrai message d'erreur.
Il est normal que vous ayez une erreur JS dans ce cas vu que le processing de la page s'arrête en plein milieu. Cela ne donne cependant aucune information sur la raison du problème.

Please Log in or Create an account to join the conversation.

More
12 years 1 month ago #167425 by MAKEDIFFERENT
Il y a pas mal de produit sur le site. Et certaines images peut être trop grosse pour le coup, y a t'il un moyen de contourner cette erreur du coup?

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 18312 bytes) in /home/trullire/public_html/administrator/components/com_hikashop/helpers/image.php on line 819

L'hebergement du site est sur Siteground

--
MAKE DIFFERENT, l'Agence web différente, Cergy.

Please Log in or Create an account to join the conversation.

More
12 years 1 month ago #167429 by Jerome
Bonjour,

Solution N°1 : Rafraichir la page encore et encore afin que toutes les images soient générées.
Si malheureusement une image est bien trop grosse pour entrer en mémoire, il faudra la supprimer et la remplacer par une image plus petite.

Cordialement,

Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.

Please Log in or Create an account to join the conversation.

More
12 years 1 month ago #167972 by MAKEDIFFERENT
Bonjour,

ça ne fonctionne pas, le rechargement pose problème. Ce que je ne comprends pas c'est que les images affichées sont normalement des thumbnails de 50x50 px, comment se peut-il que ça fasse planter le site lorsqu'ils sont chargés.

J'ai pour le moment contourner le problème pour pouvoir traiter un peu des données en cliquant sur : Tous les sous-éléments et choisir dans le menu déroulant : Sous-éléments directs.

En espérant que les produits à modifier ne soient pas dans les catégories à problème.

Une idée de résolution. De même je n'ai pas accsè aux id des photos qui posent problème et je ne sais pas le produit qui plante.

--
MAKE DIFFERENT, l'Agence web différente, Cergy.

Please Log in or Create an account to join the conversation.

More
12 years 1 month ago #167986 by nicolas
Bonjour,

HikaShop créer les miniatures à partir de l'image d'origine (bien plus grosse donc) si la miniature est manquante (ce qui est donc le cas ici).
Une solution facile pour contourner le problème, c'est d'augmenter la limite mémoire (paramètre memory_limit de votre php.ini) par exemple à 256M au moins temporairement. Cela devrait permettre à HikaShop de charger cette grosse image en mémoire pour générer sa miniature.

Please Log in or Create an account to join the conversation.

More
12 years 3 weeks ago - 12 years 3 weeks ago #170389 by MAKEDIFFERENT
Le site de l'hebergeur dit sinon ce n'est pas drôle^^:

Some applications advise that the PHP Memory be at least 128 MB. Unfortunately, you cannot have such a high value on the shared server because of possible server overloads due to excessive memory usage.

However note that this is only a recommendation and you will not experience problems in most cases.

If you find out this limitation is affecting severely your application, consider upgrading your account to a VPS server...

Il n'y a pas moyen de faire autrement?

--
MAKE DIFFERENT, l'Agence web différente, Cergy.
Last edit: 12 years 3 weeks ago by MAKEDIFFERENT.

Please Log in or Create an account to join the conversation.

More
12 years 3 weeks ago #170390 by Xavier
Bonjour,

Une autre solution serait d'éviter cette génération.
Il faut utiliser un logiciel dans le genre de "XnConvert" afin de créer vos miniatures, ensuite les uploader par FTP dans le dossier adéquat. Comme cela, pas besoin de génération d'image, et pas de surcharge.

Please Log in or Create an account to join the conversation.

Time to create page: 0.180 seconds
Powered by Kunena Forum