- Posts: 155
- Thank you received: 4
[SOLVED]Error on update
11 years 10 months ago - 11 years 9 months ago #178093
by Cattelan
[SOLVED]Error on update was created by Cattelan
-- url of the page with the problem -- :
www.ilmondodiwit.com/shop/gioielli.html
-- HikaShop version -- : 2.3.3
-- Joomla version -- : 2.5.27
-- PHP version -- : 5.3.10
-- Browser(s) name and version -- : firefox
-- Error-message(debug-mod must be tuned on) -- : look below
I cannot update to the new version normally always worked. I get this error in debug mode:
Call stack
# Function Location
1 JAdministrator->dispatch() /path/to/my/webroot/administrator/index.php:46
2 JComponentHelper::renderComponent() /path/to/my/webroot/administrator/includes/application.php:153
3 JComponentHelper::executeComponent() /path/to/my/webroot/libraries/joomla/application/component/helper.php:348
4 require_once() /path/to/my/webroot/libraries/joomla/application/component/helper.php:380
5 JController->execute() /path/to/my/webroot/administrator/components/com_installer/installer.php:18
6 InstallerControllerInstall->install() /path/to/my/webroot/libraries/joomla/application/component/controller.php:761
7 InstallerModelInstall->install() /path/to/my/webroot/administrator/components/com_installer/controllers/install.php:29
8 JInstaller->install() /path/to/my/webroot/administrator/components/com_installer/models/install.php:105
9 JInstallerComponent->install() /path/to/my/webroot/libraries/joomla/installer/installer.php:472
10 JInstallerComponent->update() /path/to/my/webroot/libraries/joomla/installer/adapters/component.php:218
11 JInstaller->parseMedia() /path/to/my/webroot/libraries/joomla/installer/adapters/component.php:851
12 JInstaller->copyFiles() /path/to/my/webroot/libraries/joomla/installer/installer.php:1494
13 JFolder::copy() /path/to/my/webroot/libraries/joomla/installer/installer.php:1618
14 JFolder::copy() /path/to/my/webroot/libraries/joomla/filesystem/folder.php:124
15 JError::raiseError() /path/to/my/webroot/libraries/joomla/filesystem/folder.php:145
16 JError::raise() /path/to/my/webroot/libraries/joomla/error/error.php:251
Thanks for your reply
-- HikaShop version -- : 2.3.3
-- Joomla version -- : 2.5.27
-- PHP version -- : 5.3.10
-- Browser(s) name and version -- : firefox
-- Error-message(debug-mod must be tuned on) -- : look below
I cannot update to the new version normally always worked. I get this error in debug mode:
Call stack
# Function Location
1 JAdministrator->dispatch() /path/to/my/webroot/administrator/index.php:46
2 JComponentHelper::renderComponent() /path/to/my/webroot/administrator/includes/application.php:153
3 JComponentHelper::executeComponent() /path/to/my/webroot/libraries/joomla/application/component/helper.php:348
4 require_once() /path/to/my/webroot/libraries/joomla/application/component/helper.php:380
5 JController->execute() /path/to/my/webroot/administrator/components/com_installer/installer.php:18
6 InstallerControllerInstall->install() /path/to/my/webroot/libraries/joomla/application/component/controller.php:761
7 InstallerModelInstall->install() /path/to/my/webroot/administrator/components/com_installer/controllers/install.php:29
8 JInstaller->install() /path/to/my/webroot/administrator/components/com_installer/models/install.php:105
9 JInstallerComponent->install() /path/to/my/webroot/libraries/joomla/installer/installer.php:472
10 JInstallerComponent->update() /path/to/my/webroot/libraries/joomla/installer/adapters/component.php:218
11 JInstaller->parseMedia() /path/to/my/webroot/libraries/joomla/installer/adapters/component.php:851
12 JInstaller->copyFiles() /path/to/my/webroot/libraries/joomla/installer/installer.php:1494
13 JFolder::copy() /path/to/my/webroot/libraries/joomla/installer/installer.php:1618
14 JFolder::copy() /path/to/my/webroot/libraries/joomla/filesystem/folder.php:124
15 JError::raiseError() /path/to/my/webroot/libraries/joomla/filesystem/folder.php:145
16 JError::raise() /path/to/my/webroot/libraries/joomla/error/error.php:251
Thanks for your reply
Last edit: 11 years 9 months ago by Cattelan.
Please Log in or Create an account to join the conversation.
Less
More
- Posts: 12953
- Thank you received: 1778
11 years 10 months ago #178099
by Mohamed Thelji
Replied by Mohamed Thelji on topic Error on update
Hello,
can you install it via ftp as it's said on the documentation : www.hikashop.com/support/documentation/5...-to-install.html#ftp
can you install it via ftp as it's said on the documentation : www.hikashop.com/support/documentation/5...-to-install.html#ftp
Please Log in or Create an account to join the conversation.
11 years 10 months ago #178584
by Cattelan
Replied by Cattelan on topic Error on update
Thanks for your reply.
I cannot find the lines in the folder.php I find only
thanks for your reply
I cannot find the lines in the folder.php I find only
Code:
// Translate path for the FTP account
$dfid = JPath::clean(str_replace(JPATH_ROOT, $FTPOptions['root'], $dfid), '/');
if (!$ftp->store($sfid, $dfid))
{
return JError::raiseError(-1, JText::_('JLIB_FILESYSTEM_ERROR_COPY_FAILED'));
}
break;
thanks for your reply
Please Log in or Create an account to join the conversation.
11 years 10 months ago #178586
by Jerome
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Replied by Jerome on topic Error on update
Hi,
Your error you got seems to be link with the copy of media files. Probably a write permission problem.
But you just past the call stack, there is no reference of the error message send to the function "raiseError".
About the Mohamed message ; he told you to try an install by FTP, not to upload the ZIP (or TAR.GZ) package but to make an install from a folder in your server (meaning that you uploaded all files in that specific folder, using FTP).
All is explained in the documentation page he gave you.
But I think that if you have some write permission issue for the media files, using the FTP install won't solve the problem.
You have to know which folder is concerned by the error and fix his permissions so Joomla will be able to update the folder correctly.
Kind regards,
Your error you got seems to be link with the copy of media files. Probably a write permission problem.
But you just past the call stack, there is no reference of the error message send to the function "raiseError".
About the Mohamed message ; he told you to try an install by FTP, not to upload the ZIP (or TAR.GZ) package but to make an install from a folder in your server (meaning that you uploaded all files in that specific folder, using FTP).
All is explained in the documentation page he gave you.
But I think that if you have some write permission issue for the media files, using the FTP install won't solve the problem.
You have to know which folder is concerned by the error and fix his permissions so Joomla will be able to update the folder correctly.
Kind regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
11 years 9 months ago #184289
by Cattelan
Replied by Cattelan on topic Error on update
Thanks for tour reply. I still could noto update until today. I didn't try FTP until now because of a time problem. Which permissions do i need to make it work?. 644 755 ?? Please give advice.
I also exceeded the number of download. Could you kindly tell me how to download the latest version.
Thanks for reply
I also exceeded the number of download. Could you kindly tell me how to download the latest version.
Thanks for reply
Please Log in or Create an account to join the conversation.
11 years 9 months ago #184370
by nicolas
Replied by nicolas on topic Error on update
Hi,
HikaShop has no limit on the number of downloads. You can download it at any time of your subscription via the menu My account>My subscriptions on our website.
If you're not sure, make the permission 777. Then, after the install has succeeded, you can restore the permissions to what they were before.
HikaShop has no limit on the number of downloads. You can download it at any time of your subscription via the menu My account>My subscriptions on our website.
If you're not sure, make the permission 777. Then, after the install has succeeded, you can restore the permissions to what they were before.
Please Log in or Create an account to join the conversation.
11 years 9 months ago #184494
by Cattelan
Replied by Cattelan on topic Error on update
Solved. It was a owner problemi of the files in the media folder. I didn't look the ownership only the permissione of the folder.
Thanks forma you replys
Thanks forma you replys
Please Log in or Create an account to join the conversation.
Time to create page: 0.172 seconds