- Posts: 19
- Thank you received: 0
Moving hikashop database, profesional help
11 years 7 months ago - 11 years 7 months ago #191148
by LudwigVan
Moving hikashop database, profesional help was created by LudwigVan
-- url of the page with the problem -- :
www.superiorimportsltd.uk
-- HikaShop version -- : 2.3.5
-- Error-message(debug-mod must be tuned on) -- : Fatal error: Class 'ConfigModelForm' not found in /home/kiaobcui/public_html/administrator/components/com_config/model/component.php on line 20
Hello, im using latest php, joomla, hikashop.
I installed sh404sef extension and my site crashed. i added 120 product also lot of modules and plugins and components..
I HAVE NOT BACKUP!
I know, its my fault.
then i was trying to fix error in phpmyadmin and i removed sh404sef tables and also ftp content and my site is not accessible (no backend, no frontend)
I cant fix this in phpmyadmin or ftp (im not so smart) so i need to create another website using joomla and import old database ( ONLY HIKASHOP PRODUCTS AND HIKASHOP COMPONENTS) I dont want to import all database, because it contain errors!
Please can you guide me how to do it safe way?
what should i do first?
PLEASE HELP
-- HikaShop version -- : 2.3.5
-- Error-message(debug-mod must be tuned on) -- : Fatal error: Class 'ConfigModelForm' not found in /home/kiaobcui/public_html/administrator/components/com_config/model/component.php on line 20
Hello, im using latest php, joomla, hikashop.
I installed sh404sef extension and my site crashed. i added 120 product also lot of modules and plugins and components..
I HAVE NOT BACKUP!
then i was trying to fix error in phpmyadmin and i removed sh404sef tables and also ftp content and my site is not accessible (no backend, no frontend)
I cant fix this in phpmyadmin or ftp (im not so smart) so i need to create another website using joomla and import old database ( ONLY HIKASHOP PRODUCTS AND HIKASHOP COMPONENTS) I dont want to import all database, because it contain errors!
Please can you guide me how to do it safe way?
what should i do first?
PLEASE HELP
Last edit: 11 years 7 months ago by LudwigVan.
Please Log in or Create an account to join the conversation.
11 years 7 months ago #191183
by LudwigVan
Replied by LudwigVan on topic Moving hikashop database, profesional help
any idea? I uploaded clean joomla 3 installation on FTP and i installed joomla template with demo content.
how to get my hikashop products on this new installation?
how to get my hikashop products on this new installation?
Please Log in or Create an account to join the conversation.
11 years 7 months ago #191221
by Jerome
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Replied by Jerome on topic Moving hikashop database, profesional help
Hi,
You can just backup all HikaShop tables ( yourprefix_hikashop_... )
Then you can install the same HikaShop package in another website and copy the HikaShop tables.
About the content, the "media/com_hikashop", the "images" and the "template/your_frontend_template/html/com_hikashop" folders will be useful.
Regards,
You can just backup all HikaShop tables ( yourprefix_hikashop_... )
Then you can install the same HikaShop package in another website and copy the HikaShop tables.
About the content, the "media/com_hikashop", the "images" and the "template/your_frontend_template/html/com_hikashop" folders will be useful.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
The following user(s) said Thank You: LudwigVan
Please Log in or Create an account to join the conversation.
11 years 7 months ago - 11 years 7 months ago #191223
by korzo
Replied by korzo on topic Moving hikashop database, profesional help
At first, create backup of the current site (files and database).
Make sure file components\com_config\model\form.php is present.
Open phpMyAdmin, go to table #___extensions. (replace #_ with your table prefix).
Find records with sh404sef in "name" column and change value in "enabled" column to 0.
Make sure file components\com_config\model\form.php is present.
Open phpMyAdmin, go to table #___extensions. (replace #_ with your table prefix).
Find records with sh404sef in "name" column and change value in "enabled" column to 0.
Last edit: 11 years 7 months ago by korzo.
Please Log in or Create an account to join the conversation.
11 years 7 months ago - 11 years 7 months ago #191312
by LudwigVan
Replied by LudwigVan on topic Moving hikashop database, profesional help
Thank you very much!. Finally, everything is done, moving db and files without troubles.
[strike]One more question:
In hikashop product menu (back-end) i can see every product correct, with photo, price and details.
I created Category listing Hikashop menu in "mainmenu" but product are not showing. You can see empty categories:
www.superiorimportsltd.uk/index.php/products .
[/strike] - this part solved, just missing module.
[strike]
I just found, the System>Configuration is missing. You can see screenshot here: ctrlv.cz/shots/2015/02/19/NeXb.png [/strike]
FIXED ALL. You can close this topic please. Thank you for your help.
PS: please, im very sorry about duplicated topics and questions. It will never happen again.
[strike]One more question:
In hikashop product menu (back-end) i can see every product correct, with photo, price and details.
I created Category listing Hikashop menu in "mainmenu" but product are not showing. You can see empty categories:
www.superiorimportsltd.uk/index.php/products .
[/strike] - this part solved, just missing module.
[strike]
I just found, the System>Configuration is missing. You can see screenshot here: ctrlv.cz/shots/2015/02/19/NeXb.png [/strike]
FIXED ALL. You can close this topic please. Thank you for your help.
PS: please, im very sorry about duplicated topics and questions. It will never happen again.
Last edit: 11 years 7 months ago by LudwigVan.
Please Log in or Create an account to join the conversation.
Time to create page: 0.195 seconds