- Posts: 178
- Thank you received: 5
Code 200 for not existing page instead 404.
11 years 6 months ago #194972
by alikon1
Code 200 for not existing page instead 404. was created by alikon1
-- HikaShop version -- : 2.3.0
-- Joomla version -- : 3.2.2
-- PHP version -- : 5.4.38
When open not existing url, instead 404 error opens main page. It's not good for SEO, as I know. How to show Error page?
-- Joomla version -- : 3.2.2
-- PHP version -- : 5.4.38
When open not existing url, instead 404 error opens main page. It's not good for SEO, as I know. How to show Error page?
Please Log in or Create an account to join the conversation.
11 years 6 months ago #194974
by Xavier
Replied by Xavier on topic Code 200 for not existing page instead 404.
Hi,
This is not handle by HikaShop. It is more a related to components like sh404sef, etc.
This is not handle by HikaShop. It is more a related to components like sh404sef, etc.
Please Log in or Create an account to join the conversation.
11 years 6 months ago - 11 years 6 months ago #195072
by alikon1
Replied by alikon1 on topic Code 200 for not existing page instead 404.
But I don't use any SEF component. Only Joomla and Hikashop.Xavier wrote: Hi,
This is not handle by HikaShop. It is more a related to components like sh404sef, etc.
Last edit: 11 years 6 months ago by alikon1.
Please Log in or Create an account to join the conversation.
11 years 6 months ago - 11 years 6 months ago #195076
by alikon1
Replied by alikon1 on topic Code 200 for not existing page instead 404.
Noticed this happens if in SEF url options -> Remove products and categories id in URLs -> No.
If select No - page will load even it doesn't exist.
For example original url /category/43-home.html, but /category/43-homehtml, /category/43-homefdgdfg.html, /category/43-home.htmladasdas works too.
If select No - page will load even it doesn't exist.
For example original url /category/43-home.html, but /category/43-homehtml, /category/43-homefdgdfg.html, /category/43-home.htmladasdas works too.
Last edit: 11 years 6 months ago by alikon1.
Please Log in or Create an account to join the conversation.
11 years 6 months ago #195100
by Xavier
Replied by Xavier on topic Code 200 for not existing page instead 404.
Hi,
Ok I see, In HikaShop when there is the id of the product, so we use it to find the product page, no matter what is present in the url after.
What can be done to force the use of the correct url for the robots is to use the Canonical urls in Configuration > Features > SEF.
This way it will add a meta tag for the canonical url and the robots will use it for SEO.
Ok I see, In HikaShop when there is the id of the product, so we use it to find the product page, no matter what is present in the url after.
What can be done to force the use of the correct url for the robots is to use the Canonical urls in Configuration > Features > SEF.
This way it will add a meta tag for the canonical url and the robots will use it for SEO.
Please Log in or Create an account to join the conversation.
11 years 6 months ago #195210
by alikon1
Search Engines ignore "rel=canonical" if it mentioned twice on a page.
Replied by alikon1 on topic Code 200 for not existing page instead 404.
I've already created post about canonical URL.Xavier wrote: This way it will add a meta tag for the canonical url and the robots will use it for SEO.
Search Engines ignore "rel=canonical" if it mentioned twice on a page.
Please Log in or Create an account to join the conversation.
11 years 6 months ago #195283
by nicolas
Replied by nicolas on topic Code 200 for not existing page instead 404.
Hi,
So let's continue the discussion on that other thread.
So let's continue the discussion on that other thread.
Please Log in or Create an account to join the conversation.
Time to create page: 0.215 seconds