- Posts: 111
- Thank you received: 0
Can't upload file to server
-- Joomla version -- : 345
-- Error-message(debug-mod must be tuned on) -- : Can't upload file
Hello,
My file is 27MB, I have updated post_max_size and the option upload_max_filesize in PHP.ini to 30MB as per indication of this post
I'm not getting any error when trying to upload the file, but when I select the file and click upload, nothing happens.
Is there a way to upload the files directly using FTP?
Thanks!
Please Log in or Create an account to join the conversation.
Can you please indicate where you're trying to perform an upload ?
That thread would help you if you have a javascript in the page
www.hikashop.com/forum/3-bug-report/8793...-t-upload-photo.html
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
I'm trying to upload the file in the Administrator - > Products.
The smaller files are uploaded without any problems.
Please Log in or Create an account to join the conversation.
So this definitively looks like a filesize issue, if you try a grater limit than 30 is that working ?
You maybe have a server restrictions that is not allowing these sizes and is not reading the php.ini properties for these values.
Please Log in or Create an account to join the conversation.
It doesn't return any error, after clicking the upload button, nothing happens.
Please Log in or Create an account to join the conversation.
Did you take a look at the other thread ?
Because your solution is already there.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
Yes, I did. My media Manager and php settings are both defined to upload files up to 50 MB.
But when I click the upload button in Hikashop for a file of 27MB, I get the error in Dev Tools:
POST error www.domain.com/administrator/index.php?o..._file&tmpl=component net::ERR_CONNECTION_ABORTED
Please Log in or Create an account to join the conversation.
Can you please check in your PHP error log that you do not have a PHP fatal error ?
If the connection is aborted, it could be related to a server/php issue.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
I've enabled "Error reporting" to "Maximum" in Joomla Global Config and reproduced the error again, but no PHP error message.
Please Log in or Create an account to join the conversation.
Because it's an XHR upload ; you're not able to see the content of that call except if you're using your browser console and catch all server requests...
You really need to take a look at the PHP error log file.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
Here it is in attachment. Thanks a lot for helping!
Please Log in or Create an account to join the conversation.
I'm sorry but there is no attachment in your message.
Depending the size and the nature of the file ; it could be refused by the forum.
In that case you can use the support email (support at hikashop.com).
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
We got the file.
The only error I see in it is this one:
So the problem is not a fatal error in PHP. Maybe there is some kind of security module in your apache server doing that.
Anyway, an easy way to circumvent the problem is to directly upload the file in media/com_hikashop/upload/safe/ via FTP and then use the other button next to the upload button to enter the filename of your file in the file popup so that the file gets linked to your product.
Please Log in or Create an account to join the conversation.
I guess this solves the problem.
Thank you.
Please Log in or Create an account to join the conversation.
I have typed the file name instead of uploading the file as usual (I uploaded via FTP to /safe directory).
Now, users are downloading a file with 0Kb with the name "safe" instead of the actual file.
Please Log in or Create an account to join the conversation.
Can you do a screenshot of the settings of your file ?
Can you make sure that the "upload secure folder" setting of the HikaShop configuration is correct ?
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
In the field "file path" ; you must provide the filename of the file.
Please understand that the "name" is the name of the file which will be display in the email, in the order summary, etc. It is not the file name.
Providing a blank file path will not work and result the side effect you're facing.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
Please Log in or Create an account to join the conversation.
Your screenshot is for the product main options.
You upload a file using FTP in the "safe" folder ; so you should know the name of that file (aka : filename).
www.hikashop.com/support/documentation/i...uct-form.html#images
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.