- Posts: 515
- Thank you received: 22
bugs
- jouwnaambord.nl
-
Topic Author
- Offline
Less
More
10 years 8 months ago #227068
by jouwnaambord.nl
bugs was created by jouwnaambord.nl
-- url of the page with the problem -- :
www.jouwnaambord.nl/
-- HikaShop version -- : 2.6.1
-- Joomla version -- : 3.4.8
-- Browser(s) name and version -- : chrome 47
Some bugs.
1. When adding/editing an order by hand (f.e. changing the user in an order) the database isn't updated with the corresponding user_id (is set to "0"). Furthermore the invoicenumber isn't set right when adding a new order by hand.
2. In the frontend in the orderlisting the paymentmethod set in the backend isn't picked in the frontend shown paymentmethod. There's just a listing of the paymentmethods and no preselected payment. (wich was before in hikashop 2.5)
3. When editing the view files the page turns empty when saving.
Beste regards,
Michel Pouli
-- HikaShop version -- : 2.6.1
-- Joomla version -- : 3.4.8
-- Browser(s) name and version -- : chrome 47
Some bugs.
1. When adding/editing an order by hand (f.e. changing the user in an order) the database isn't updated with the corresponding user_id (is set to "0"). Furthermore the invoicenumber isn't set right when adding a new order by hand.
2. In the frontend in the orderlisting the paymentmethod set in the backend isn't picked in the frontend shown paymentmethod. There's just a listing of the paymentmethods and no preselected payment. (wich was before in hikashop 2.5)
3. When editing the view files the page turns empty when saving.
Beste regards,
Michel Pouli
Please Log in or Create an account to join the conversation.
10 years 8 months ago #227072
by nicolas
Hi,
1. I'm not able to reproduce the issue. The order_user_id is correctly changed when changing the user in an order on our end with the latest version.
2. Change the line:
to:
in the file "listing" of the view "order" for your frontend template and that should fix the problem.
3. This looks like a server error. Turn on the error reporting on your Joomla configuration and try again. Do you get any error message ? If so what message exactly ?
1. I'm not able to reproduce the issue. The order_user_id is correctly changed when changing the user in an order on our end with the latest version.
2. Change the line:
Code:
echo JHTML::_('select.genericlist' ,$paymentvalues ,'new_payment_method' ,' class="inputbox" size="1"' , 'value', 'text', '', 'new_payment_method'.$row->order_id);
Code:
echo JHTML::_('select.genericlist' ,$paymentvalues ,'new_payment_method' ,' class="inputbox" size="1"' , 'value', 'text', $row->order_payment_method.'_'.$row->order_payment_id, 'new_payment_method'.$row->order_id);
3. This looks like a server error. Turn on the error reporting on your Joomla configuration and try again. Do you get any error message ? If so what message exactly ?
The following user(s) said Thank You: jouwnaambord.nl
Please Log in or Create an account to join the conversation.
- jouwnaambord.nl
-
Topic Author
- Offline
Less
More
- Posts: 515
- Thank you received: 22
10 years 8 months ago #227166
by jouwnaambord.nl
Replied by jouwnaambord.nl on topic bugs
Hi Nicolas,
1. Just downloaded the latest version, seems to work fine.
2. Changed that line and saw there wasd an old adjustment I made. Removed it and it works fine.
3. There's no error message. When hit the save button, all the text is removed and leaves a blank edit screen. see screenshots
Thanks!
1. Just downloaded the latest version, seems to work fine.
2. Changed that line and saw there wasd an old adjustment I made. Removed it and it works fine.
3. There's no error message. When hit the save button, all the text is removed and leaves a blank edit screen. see screenshots
Thanks!
Please Log in or Create an account to join the conversation.
10 years 8 months ago #227183
by Jerome
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Hi,
3. I think that you have some security plugin in Joomla or in your web server.
Because you submit some PHP/HTML content ; a security plugin could see that as a critical and unsecured data.
In that case, the plugin could empty completely the variable content and just let an empty variable for HikaShop.
We already saw that kind of issue before ; sometimes though a Joomla plugin, sometimes though a web server module.
Regards,
3. I think that you have some security plugin in Joomla or in your web server.
Because you submit some PHP/HTML content ; a security plugin could see that as a critical and unsecured data.
In that case, the plugin could empty completely the variable content and just let an empty variable for HikaShop.
We already saw that kind of issue before ; sometimes though a Joomla plugin, sometimes though a web server module.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
The following user(s) said Thank You: jouwnaambord.nl
Please Log in or Create an account to join the conversation.
- jouwnaambord.nl
-
Topic Author
- Offline
Less
More
- Posts: 515
- Thank you received: 22
10 years 8 months ago #227268
by jouwnaambord.nl
Replied by jouwnaambord.nl on topic bugs
Hi Jerome,
Yes, thank you. That was the problem. I have jHackGuard installed and this plugin indeed was the cause. I added my IP address to the whitelist and the problem is solved.
Regards,
Yes, thank you. That was the problem. I have jHackGuard installed and this plugin indeed was the cause. I added my IP address to the whitelist and the problem is solved.
Regards,
Please Log in or Create an account to join the conversation.
Time to create page: 0.189 seconds