Skip to main content

Error 500 accessing Buyer Control Panel

More
9 years 10 months ago - 9 years 10 months ago #255950 by DACOG
-- HikaShop version -- : 2.6.4 [1610261505]
-- Joomla version -- : 3.6.4
-- PHP version -- : 5.4.45
-- Browser(s) name and version -- : Firefox
-- Error-message(debug-mod must be tuned on) -- : Error 500 access buyer control panel. I run HikaMarket and I can access Hikamarket control panel without problem. What could be causing the error on access buyer control panel?

Until last week, everything worked well. Then i added some links and then buyer control panel stopped working. The screenshot of the error window is attached.
Code:
ERROR LOG ------------------------------------------------------------------------------- Blocking reason: adminpw ------------------------------------------------------------------------------- Date/time : 2016-11-21 17:27:56 GMT URL : http://www.bettasella.com/administrator/?pPP User : Guest IP : 84.227.187.254 Country : CH Continent : EU UA : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0 ------------------------------------------------------------------------------- Blocking reason: adminpw ------------------------------------------------------------------------------- Date/time : 2016-11-21 22:00:09 GMT URL : http://www.bettasella.com/administrator/index.php?option=com_languages User : Guest IP : 84.227.187.254 Country : CH Continent : EU UA : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0 ------------------------------------------------------------------------------- Blocking reason: adminpw ------------------------------------------------------------------------------- Date/time : 2016-11-23 16:55:14 GMT URL : http://www.bettasella.com/administrator/index.php?option=com_hikashop&tmpl=component&ctrl=config&task=language&code=ar-AA User : Guest IP : 84.227.187.254 Country : CH Continent : EU UA : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0 ------------------------------------------------------------------------------- Blocking reason: adminpw ------------------------------------------------------------------------------- Date/time : 2016-11-23 21:27:08 GMT URL : http://www.bettasella.com/administrator/index.php?option=com_hikamarket&ctrl=config&task=language&code=af-ZA&tmpl=component User : Guest IP : 84.227.187.254 Country : CH Continent : EU UA : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

What could be the probable solution? thanks.
Last edit: 9 years 10 months ago by Jerome. Reason: [code] is nice

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #255969 by nicolas
Hi,

The error adminpw means that you tried to access your backend without the admin password in the URL:
www.akeebabackup.com/support/admin-tools...-reason-adminpw.html
So it's not linked to your 500 error on the frontend.
I unterstand that the error log you looked at is the one from Joomla/Admin tools.
Could you instead look at the PHP error log of your server ? It should contain a "Fatal error" message corresponding to the 500 error page you see on your frontend. It will provide critical information to help you.

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #255996 by DACOG
Hi Nicholas

I have solved the problem. It had to do with ACL - user not having the right permission to access the control panel of Hikashop.

One more question though:

What is your recommendation about configuring vendor monthly subscription service?

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #256000 by nicolas
Hi,

You'll have to use a subscription extension. For example, Emerald is integrated with HikaShop and can do that.
And you'll have to configure a susbcription plan which will add a user group to the user upon the subscription starting, and remove it when it expire, and send notification emails.
Then, you can configure HikaMarket to allow users to be vendors on your website based on their user group.
You can read more about that in the "Mode: Vendor paid subscription" section of www.hikashop.com/support/documentation/1...tml#tuto_market_conf

Please Log in or Create an account to join the conversation.

Time to create page: 0.183 seconds
Powered by Kunena Forum