- Posts: 220
- Thank you received: 0
API notify internal server error 500
- clairewang
-
Topic Author
- Offline
-- Joomla version -- : 3.7
-- PHP version -- : 7.0.21
-- Browser(s) name and version -- : Chrome 59
Hi dear all,
The order auto-emails back shows up API notify URL failure, internal server error 500. If I upgrade to HikaShop from current 2.5 version to the newest, will the problem be resolved? Is the new Business version necessary? Thank you so much.
Please Log in or Create an account to join the conversation.
There is no such error message in HikaShop.
Where do you get that error message ? Can you provide a screenshot ? What is the URL of the page ? What are the instructions to reproduce the issue ?
Please Log in or Create an account to join the conversation.
- clairewang
-
Topic Author
- Offline
- Posts: 220
- Thank you received: 0
The error happens when the order is paid and the auto email be received like the screenshot. There is no error in the url page, only in the email. But the email url showed up isn't the one should be landed. Website is facianohair.com.tw I doubt you can reproduce the result because you will need to swift the card, and the email only is received by the default admin email .
Please Log in or Create an account to join the conversation.
There is no such email in HikaShop.
And that error message indicates a problem in the payment plugin pay2go that you're using.
Are you sure that this plugin is compatible with HikaShop 2.5 ?
Also, you should get the fatal error message corresponding to that problem in the PHP error log of your web server. So please look in there for it. That will be crutial in understanding what's not working.
Please Log in or Create an account to join the conversation.
- clairewang
-
Topic Author
- Offline
- Posts: 220
- Thank you received: 0
Please Log in or Create an account to join the conversation.
- clairewang
-
Topic Author
- Offline
- Posts: 220
- Thank you received: 0
Sorry, the email sent out late. It seems the problem is still there. PaytoGo asks me to check log record. Do you know how to check up? Thank you so much.
Please Log in or Create an account to join the conversation.
What check log record ? The Payment error log ? Something else ?
www.hikashop.com/support/documentation/5...nfig.html#main_files
I'm sorry but we did not developed the PayToGo plugin so we can't provide useful help for it.
But if you have questions regarding HikaShop, then we can.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
- clairewang
-
Topic Author
- Offline
- Posts: 220
- Thank you received: 0
Please Log in or Create an account to join the conversation.
I'm not sure what you mean by " Is Hikashop 2.5 business version can go well with Hikashop newest version?"
But HikaShop is indeed not compatible with PHP 7.0.21 as it didn't exist when HikaShop 2.5 was released.
So updating might help. However, the error looks like something related to the payment plugin you're using so it's not guaranteed that it will change anything.
It's worth trying and if that doesn't help, revert and contact the developer of the pay2go plugin for help.
Please Log in or Create an account to join the conversation.
- clairewang
-
Topic Author
- Offline
- Posts: 220
- Thank you received: 0
Please Log in or Create an account to join the conversation.
I'm sorry but I'm not able to understand your message.
But yes, you can update an HikaShop 2.5 to an HikaShop 3.1 ; afterwards if you change the edition, you'll change the available features.
Regards,
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
- clairewang
-
Topic Author
- Offline
- Posts: 220
- Thank you received: 0
1 If I upgrad Hikashop Starter to 3.6, will the Hikashop Business version 2.5 work well with Starter 3.6?
2 Whenever I want to add the payment methods, the page goes to this in the attachment. Is it about PHP7.0 not compatible with Hikashop 2.5?
Thank you so much.
Please Log in or Create an account to join the conversation.
2 -yes, you can update an HikaShop 2.5 to an HikaShop 3.1
But HikaShop is indeed not compatible with PHP 7.0.21 as it didn't exist when HikaShop 2.5 was released.
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
- clairewang
-
Topic Author
- Offline
- Posts: 220
- Thank you received: 0
Please Log in or Create an account to join the conversation.
Is there something you don't understand in my message ?
yes, you can update an HikaShop 2.5 to an HikaShop 3.1 ; afterwards if you change the edition, you'll change the available features.
Jerome - Obsidev.com
HikaMarket & HikaSerial developer / HikaShop core dev team.
Please Log in or Create an account to join the conversation.
- clairewang
-
Topic Author
- Offline
- Posts: 220
- Thank you received: 0
Thank you a lot.
Please Log in or Create an account to join the conversation.
First there is no 3.6 version. The latest version of HikaShop is 3.1.1. So I'm not sure what 3.6 you're talking about ?
Supposing that you actually have HikaShop Business 2.5.0 installed on your website:
- you can install the install package of HikaShop Starter 3.1.1 on it. You will then get HikaShop Starter 3.1.1 installed on your website, which means that it will be compatible with PHP 7. However, this also means that you'll loose the features of HikaShop Business.
- you can install the install package of HikaShop Business 3.1.1 on it. You'll then get HikaShop Business 3.1.1 installed on your website, which means that it will be compatible with PHP 7 AND you'll keep all the features of HikaShop available only in the Business edition of HikaShop.
Please Log in or Create an account to join the conversation.