Skip to main content

4.1.0 Product page 404 error

More
7 years 4 months ago #306792 by Twincarb
-- HikaShop version -- : 4.1.0
-- Joomla version -- : 3.9.6
-- PHP version -- : 7.3.5
-- Browser(s) name and version -- : all
-- Error-message(debug-mod must be tuned on) -- : 404 Error

While testing out 4.1.0 on a server using plesk control panel I discovered that the product pages failed to load throwing a 404 error the page isn't being rendered correctly as the page is loaded with no template, the product showing at the top of the page and the 404 error showing below.

I am currently away on the road this week, but i will attempt to get a clean install set up with a vanilla Joomla install and confirm i am able to replicate it for you to see.

Please Log in or Create an account to join the conversation.

More
7 years 4 months ago #306802 by nicolas
Hi,

We would indeed need more information to be able to look into it. So far, no one reported such issue.
Make sure that you provide the version you were using before, try to reproduce with the "error reporting" and "debug mode" settings of the Joomla configuration activated (and give a screenshot of the result), a screenshot of the settings of the product and the link to the product page. That will allow us to look into it.

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago - 7 years 2 months ago #308993 by Twincarb
Hi,

I have had a look today to see whats causing the error, I have tracked it down to com_hikashop/views/product/view.html.php If I edit out the lines below then the page displays correctly. If the lines are left in the product is displayed at the top of the page and then the 404 not found is displayed below. I use ACL on different categories and products and without the lines below it appears to work correctly.
Code:
595 if(!count($pageInfo->filter->cid)) { 596 throw new Exception(JText::_('CATEGORY_NOT_FOUND'), 404); 597 }

The version i was using last was 4.0.3 and have commented out the above lines in 4.2.0
Code:
Category not found /var/www/vhosts/example.com/components/com_hikashop/views/product/view.html.php:596 Call stack # Function Location 1 () JROOT/components/com_hikashop/views/product/view.html.php:596 2 ProductViewProduct->listing() JROOT/components/com_hikashop/views/product/view.html.php:28 3 ProductViewProduct->display() JROOT/administrator/components/com_hikashop/helpers/helper.php:766 4 hikashop_getLayout() JROOT/modules/mod_hikashop/mod_hikashop.php:73 5 include() JROOT/plugins/system/t3/includes/joomla4/ModuleHelper.php:201 6 Joomla\CMS\Helper\ModuleHelper::renderModule() JROOT/components/com_hikashop/views/product/tmpl/show.php:391 7 include() JROOT/libraries/src/MVC/View/HtmlView.php:697 8 Joomla\CMS\MVC\View\HtmlView->loadTemplate() JROOT/administrator/components/com_hikashop/helpers/helper.php:2263 9 hikashopView->loadTemplate() JROOT/libraries/src/MVC/View/HtmlView.php:230 10 Joomla\CMS\MVC\View\HtmlView->display() JROOT/administrator/components/com_hikashop/helpers/helper.php:2246 11 hikashopView->display() JROOT/components/com_hikashop/views/product/view.html.php:29 12 ProductViewProduct->display() JROOT/libraries/src/MVC/Controller/BaseController.php:672 13 Joomla\CMS\MVC\Controller\BaseController->display() JROOT/administrator/components/com_hikashop/helpers/helper.php:1984 14 hikashopController->display() JROOT/administrator/components/com_hikashop/helpers/helper.php:1725 15 hikashopController->show() JROOT/libraries/src/MVC/Controller/BaseController.php:710 16 Joomla\CMS\MVC\Controller\BaseController->execute() JROOT/administrator/components/com_hikashop/helpers/helper.php:1962 17 hikashopController->execute() JROOT/components/com_hikashop/hikashop.php:92 18 require_once() JROOT/libraries/src/Component/ComponentHelper.php:402 19 Joomla\CMS\Component\ComponentHelper::executeComponent() JROOT/libraries/src/Component/ComponentHelper.php:377 20 Joomla\CMS\Component\ComponentHelper::renderComponent() JROOT/libraries/src/Application/SiteApplication.php:194 21 Joomla\CMS\Application\SiteApplication->dispatch() JROOT/libraries/src/Application/SiteApplication.php:233 22 Joomla\CMS\Application\SiteApplication->doExecute() JROOT/libraries/src/Application/CMSApplication.php:196 23 Joomla\CMS\Application\CMSApplication->execute() JROOT/index.php:49
Last edit: 7 years 2 months ago by Twincarb.

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago #309009 by nicolas
Hi,

So you mean you have the error even with HikaShop 4.2.0 ?
This indicates that in the settings of one of the modules you selected in the "modules under the product page" setting of the HikaShop configuration, you've selected an unpublished category.
Could you check on that ?

Please Log in or Create an account to join the conversation.

More
7 years 2 months ago #309015 by Twincarb
Thanks Nicolas,

The module it was pointing to was unpublished, and category was set to 'none'. Giving it a valid category or removing the module from Hikashop configuration has cleared the issue.
Thanks again for your assistance.

Dave

Please Log in or Create an account to join the conversation.

Time to create page: 0.227 seconds
Powered by Kunena Forum